ESXi

 View Only
  • 1.  vmx status

    Posted Jul 16, 2014 02:52 PM

    I have 2 hosts esxi 5.1: ESXi12 and ESXi13

    When I try to browse a folder (VM) inside a datastore I notice that the browse is very slow and when the folder opens I see the .vmx file not recognized (without the typical icon).

    This situation happens on ALL the VMs running on ESXi13 .

    If I vmotion one VM from that host to ESXi12, browsing the folder is fast and the vmx is recognized.

    I've rebooted the host ESXi13 but the problem is not solved.

    You can see the result of a browse of a folder of a VM, first when the VM is on ESXi13 (.vmx file not recognized) and second  when the VM is on ESXi12 (.vmx file not recognized)

    The same situation happens for ALL the VM!

    Any help please?



  • 2.  RE: vmx status

    Posted Jul 16, 2014 03:14 PM

    Last time I have seen something similar was due to file locks, you can investigate this by following this kb article VMware KB: Investigating virtual machine file locks on ESXi/ESX



  • 3.  RE: vmx status

    Posted Jul 16, 2014 03:22 PM

    Thanks I've already investigated the file locks but everything seems to be right....

    I see aVM.vmx.lck file when the VM are powerd on and this file disappear when the VM are powered off.

    It exist even if the datastore is VMFS.



  • 4.  RE: vmx status

    Posted Jul 17, 2014 08:43 AM

    Just to understand this better, these VM are registered in vCenter and they power-on ok without any issues, you are not actually experiencing any issues but this is just more for your own understanding.



  • 5.  RE: vmx status

    Posted Jul 17, 2014 09:02 AM

    Exactly, The VMs are registered in vcenter, i can power on/off them without problems, I can vmotion them without problems.

    So this is not really an issue but I'm scared.....I'm thinking that ESXi13 has some problems with the LUN/datastore but I cannot understand wich type of problem.

    I've double checked the file locks and they are OK.



  • 6.  RE: vmx status

    Posted Jul 17, 2014 09:16 AM

    Check /var/log/vmkwarning.log and /var/log/vmkernel.log for any problems with the datastore.



  • 7.  RE: vmx status

    Posted Jul 17, 2014 02:46 PM

    Hey vmb01,

    Since this is only happening on two of your ESXi hosts out of what looks like 13 or more, I would think this is possibly a HBA, or pathing issue since you said you have already investigated file locks and ruled them out.

    1.)  Check to make sure all paths to the storage is in good health.  The easiest way to do this is to right click on the datastore in question and manage paths.

    2.)  Check your VMkernel.log to see if there is any path errors or all path down errors(APD)

    3.)  Check your Fibre zoning, there is a chance that your zoning could be causing the issue

    4.)  Make sure your HBA's are on the same firmware version and driver version as your working hosts

    5.)  Check ESXTOP to see what your DAVG is on that datastore/hba and make sure there is no vmkernel queueing

    Has anything changed on these systems since you first noticed this?  An upgrade, patches, ect?



  • 8.  RE: vmx status

    Posted Jul 16, 2014 04:02 PM

    Hi

    Welcome to communities.

    please check MTU on VSwitch  at 9000

    and  jumbo frames enabled on your VMKernel



  • 9.  RE: vmx status

    Posted Jul 16, 2014 05:01 PM

    Why MTU? I'm using FC storage