Backup & Recovery

 View Only
  • 1.  VMware Data Protector issues

    Posted Oct 29, 2012 02:09 AM

    Hi all,

    I have struggled for many months with the unreliable nature of VMware Data Recovery and decided to bite the bullet over the weekend and install VMware Data Protector. After much cursing and swearing I finally got it working (my fault for not planning properly and just jumping in).

    Anyway, I am having the same issues with VMware Data Protector as I had before. Some Windows Server 2008 R2 machines will not back up. I get the following error messages:

    Execution error: E10055: Failed to attach disk

    I've followed this article: http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2035736 but it didn't seem to resolve the issues.

    I also tried this in addition but to no avail: http://www.bluemunkey.com/?p=338

    I would love to use this product for backups but it is just too flakey and I really starting to get tired of VMware's backup products not working as they should. Strangely enough Server 2003 machines back up flawlessly, it's just Server 2008 R2 machines.

    Has anyone resolved this issue and would they care to share?

    Thanks,

    Richard



  • 2.  RE: VMware Data Protector issues

    Posted Oct 29, 2012 02:51 PM

    I also had this problem but followed the instructions in your first link and my problem was solved.

    I was also able to get VSS to work with a 2008 R2 SQL server to achieve an Application Consistent Backup by installing the Windows 2008 SDK.

    Are you still experiencing the same problem after setting the disk.EnableUUID to false? 



  • 3.  RE: VMware Data Protector issues

    Posted Oct 29, 2012 06:59 PM

    I haven't installed the SDK on any of my servers yet, it's 3GB of download and install per server! But I did grab a copy of vshadow.exe for Server 2008 R2 and I sorted out a script to make it run properly as per the second link, but still no joy.

    Thanks,

    Richard



  • 4.  RE: VMware Data Protector issues

    Posted Nov 01, 2012 03:32 PM

    If your backup job is failing, you can log on to your VDP appliance's VM and go to /usr/local/avamarclient.

    This is where the proxy logs are located.  There should be 8 proxies running on your VDP.

    After you kick off your job, wait about 30 seconds and do an ls, and then you can see which proxy is being used.

    cd into that directory and then you can look at the ".log" file from the job you submitted.  The name of the file should be the "jobName" concatenated with a "job-id".log

    The information in the logs should give you further insight as to why the jobs are failing.