ESXi

 View Only
  • 1.  VMDP & disappearing PCIe device

    Posted Apr 07, 2011 04:13 AM

    When I first booted my ESX box with a Lenovo Geforce 310 DMS59, the graphics card showed up as a device compatible with VMDP.
    When I tried assigning it to a VM, there were problems and the VM would not boot.

    So I went into my system BIOS and configured it to use the integrated graphics for the boot screen.
    Re-installed ESX, and... now the Lenovo Geforce 310 DMS59 no longer shows up?

    Do I need to install additional drivers to have this card recognized if it is not being used as the default graphics card?
    Something else I have to tweak?

    Thank you for any help pointing out what I've done wrong.



  • 2.  RE: VMDP & disappearing PCIe device

    Posted Apr 07, 2011 05:28 AM

    You don't have to add additional drivers to configure a device for VMDirectPath.  What sort of error did you have initially and what OS were you using in the guest?



  • 3.  RE: VMDP & disappearing PCIe device

    Posted Apr 07, 2011 04:21 PM

    When I first added the PCIe graphics card (Lenovo 512MB NVIDIA GeForce 310 DMS59 Dual-DVI, Dual-VGA Graphics Card)  it showed up under 'configuration>advancedsettings>VMDirectPath Configuration' as:

    00:01.0 | Intel Corporation 82Q35 Express PCI Express Root controller

      -  01:00.0 | nVidia Corporation VGA compatible controller

      -  01:00.1 | nVidia Corporation Unknown


    I 'configure passthrough device' and rebooted the system.  The device showed up as 'running in passthrough mode' When I added the passthrough device to the VM, it is refered to as:

    Hardware type: PCI Device

    PCI/PCIe Device: 01:00.0 | nVidia Corporation Unknown

    and tried to start it I got the error:

    Failed to power on VM
    Could not power on VM : Admission check failed for memory resource See the VMware ESX Resource Management Guide for information on resource management settings.
    Group host/user: Invalid memory allocation requested for VM vmm0:New_Virtual_Machine. (min: 524288 pages, max: -1, minLimit: -1, shares: -1)
    Group vm.4250: Cannot admit VM: Memory admission check failed. Requested reservation: 524288 pages

    If I then remove the PCI device association with the VM, the error persists and the VM will not boot.  Deleting and rebuilding the VM removes the error until I try to attach the PCIe device again.

    If I configure the BIOS to use integrated graphics as the boot display default, the PCIe graphics card is not recognized at all under the 'Mark devices for passthrough'.

    If the dual-dvi / dual-vga nature of this graphics card makes it exceptionally unusable as a passthrough device, I will look for an alternative.

    Thank you.



  • 4.  RE: VMDP & disappearing PCIe device

    Posted Apr 07, 2011 05:54 PM

    So I feel a bit stupid,
    The ' -1' values were throwing me off.
    The VM had too much memory assigned to it...
    Though I dont entirely understand why it would boot with 2GB assigned, but fail once the PCIe device was added.

    Oh well, solved! (Mostly)

    Now I get ' The task was cancled by a user' whenever I try to start the VM.