View Only
Expand all | Collapse all

Very slow speed on SSD

  • 1.  Very slow speed on SSD

    Posted Feb 13, 2017 04:36 PM

    Hi experts,

    I am getting strange behavior for ESXI6.5 (installed as test at my home clone server). Like i have installed 2 SSD, one is Intel M.2 and another is transcend SATA III SSD. from both SSD i have created datastore. But i am getting different speed on the 2 SSD like on intel i am getting full speed but on transcend i am getting only 16mbps speed. tried to search google, but didnt got any solution. my ESXI is installed on intel M.2 SSD.

    Pls find the speed diff (2.02 vs 22.77 MB/s) t10.ATA is transcend and NVMe is Intel M.2

    Pls suggest what to do.

    My server config:

    Processor: Intel(R) Core(TM) i7-6800K

    RAM: 128GB

    Motherboard : GA-X99-Ultra Gaming

    No RAID

  • 2.  RE: Very slow speed on SSD
    Best Answer

    Posted Feb 14, 2017 06:49 AM

    Hi Rajib,

    welcome to the forums!

    ESXi 6.5 includes a new native driver (vmw_ahci) for SATA AHCI controllers, but that introduces performance problems with a lot of controllers and/or disks.

    Try to disable the native driver and revert to the older sata-ahci driver by running

    esxcli system module set --enabled=false --module=vmw_ahci

    in an ESXi shell. Reboot the host to make the change effective.

    - Andreas

  • 3.  RE: Very slow speed on SSD

    Posted Feb 21, 2017 07:17 AM

    This fixed it for me.

    Was experiencing Latency of > 1000ms and Write Speed of 1Mbps on my M.2 SSD (Transcend 2260). Motherboard is a H110T/CSM.

    Thanks for the advice.

  • 4.  RE: Very slow speed on SSD

    Posted Feb 25, 2017 03:58 PM

    Thanks Andreas,

    Your suggestion worked for me, now i am getting avg speed 250Mbps from SATA III SSD .

    Hope will get the full I/Ops from SSD.


    Rajib Imran

  • 5.  RE: Very slow speed on SSD

    Posted Mar 31, 2017 10:36 AM

    Thanks peetz, you saved me: I spent hours trying to determine why my 1TB Crucial MX300 M.2 2280 SSD had such abysmal performance (updating BIOS on my skull canyon, updating ESXi, etc...), and now, thanks to your post, I'm getting ~500MB/s read write.

  • 6.  RE: Very slow speed on SSD

    Posted Apr 05, 2017 07:41 PM

    Does this or something like it apply to ESXi 5.5 ?

    I have an IBM X3550M5 and boot ESXi off an internal SD card.

    The ESXi was installed from the latest download of 5.5 (U3?)

    There is a single SSD drive for VMware View desktops -

    But actions like clone to replica take well more than the 90-minute limit for a simple Win7 VM.

    Even creating the clone files (not replica) for View desktops was impossible.

    Trying to migrate a 36GB Win2012R2 Terminal server to the SSD is about 50% done after 3 hours.

    The SSD is unusable...


  • 7.  RE: Very slow speed on SSD

    Posted May 19, 2017 10:19 PM

    What is the permanent fix for this issue, should we expect a corrected native driver from VMware, or will this require a firmware upgrade on the part of the drive vendors?

  • 8.  RE: Very slow speed on SSD

    Posted May 31, 2017 09:08 PM

    I can confirm that this works for me to increase SSD access speed on my Intel NUC (BOXNUC7I7BNH).

  • 9.  RE: Very slow speed on SSD

    Posted Jul 28, 2018 08:03 PM

    This was my problem as well.

    WARNING: Doing this at least for me erases all the VMs on the aforementioned drive. Migrate as needed.

  • 10.  RE: Very slow speed on SSD

    Posted Aug 27, 2018 10:22 AM

    Please tell the noob, does this problem affect ESXi 6.7? And how can I check, does it affect my system?
    And what will happen with my ESXi, installed on one of the SSD's?

  • 11.  RE: Very slow speed on SSD

    Posted Nov 02, 2018 10:09 PM

    tried the command on a 6.7.

    Deploying an OVA and I am getting 22.82....

    I have a Samsung 860 EVO mSATA 1Tb SSD.

    i re-enabled it, I got max 11.81.

    Kind of crappy either way. Not SSD speeds IMO.

  • 12.  RE: Very slow speed on SSD

    Posted Sep 28, 2021 11:50 AM

    Have a similar problem with my Intel NUC 10i7FNH2. When I do esxcli system module set --enabled=false --module=vmw_ahci
    then reboot my esxi does not detect my drives anymore. This is esxi 7.0U2. Can't seem to find a way to make it use a different driver other than the vmw_ahci.

    When I use wmv_ahci it does work but the speeds to my Samsung 860 drives is abysmal. 

  • 13.  RE: Very slow speed on SSD

    Posted Sep 29, 2021 03:04 AM

    I have a similar problem. I'm running esxi 6.7 at home, for some simple VMs, on an Asrock Fatal1ty X399 Professional Gaming motherboard with a 16-core AMD ThreadRipper CPU.

    My best research shows that all the SATA ports hang off the x399 chipset. That's gotta be what driver is needed. Right?


    I was using esxi 7, but the SATA wouldn't load at all. So I wiped the drive and installed 6.7. With vmw_ahci disabled, the local drives are not loaded at all, but with it enabled they all seem to get max read/write around 40MBps.

    I'm trying to use an HP SSD S700 for the local VM system drives, and NFS on Unraid (3TB platter x for data drives. For throughput, the NFS is almost as fast as the local drives! The latency of the local drives is much faster, so even with 40MBps it's better on the local SSD.  I'd really like to get closer to the 500MBps this drive was getting with Hyper-V.

    Anyone have any new ideas?

  • 14.  RE: Very slow speed on SSD

    Posted Apr 28, 2022 11:26 AM

    Esxcli comand working on 6.7.0 Update 3 (Build 19195723) on Mega RAID 9361-8i (raid 1) (5k iops/20ms latency vs 65k iops/1ms latency)

  • 15.  RE: Very slow speed on SSD

    Posted Feb 21, 2017 01:03 PM

    I was also having this issue, after 3 days trying to troubleshoot found this solution on a blog post.

    One issue I still have is that my 4 port Syba PCIe controller card now vanishes after disabling vmw_ahci and I am restricted to using the SATA ports on the motherboard.  Is there also a workaround for this?

  • 16.  RE: Very slow speed on SSD

    Posted Jun 26, 2019 08:07 AM


    Running 6.7u2XXX

    this does not help to solve my problem... esxcli system module set --enabled=false --module=vmw_ahci

    EDIT. However, the native driver did increate the performance around 17% of read and write speed.

    Doing further testing and look like Hyper-V is ways faster then esxi.. tested using same box and same storage....

    So believe this is esxi driver limitation.