ESXi

 View Only
Expand all | Collapse all

Very slow performance with the vSphere Web Client

  • 1.  Very slow performance with the vSphere Web Client

    Posted Nov 14, 2013 09:58 PM

    I'm testing the vSphere Web Client, but I'm finding it unbearably slow - it takes almost 5 minutes just to log on, and every click after I'm in takes a good 30 seconds before the new page is done loading. I think I spent a good 10 minutes in total simply getting to the screen where I could power on a VM, which is something that can been done in less than a minute using the traditional desktop client.

    Have I horribly misconfigured the web client in some way?



  • 2.  RE: Very slow performance with the vSphere Web Client

    Posted Nov 14, 2013 10:01 PM

    Hi Faize,

    What is the spec of the machine your web client is on?

    Also note, that Web client is using Flash still. Some slowness is to be expected.



  • 3.  RE: Very slow performance with the vSphere Web Client

    Posted Nov 14, 2013 10:42 PM

    Just to clarify, are you asking about the spec of the ESXi server, the spec of the VM that's running vCenter Server, or the spec of the laptop that's running the web browser?



  • 4.  RE: Very slow performance with the vSphere Web Client

    Posted Nov 14, 2013 10:44 PM

    Primarily the spec of the VM that is hosting web client (ie vCenter)



  • 5.  RE: Very slow performance with the vSphere Web Client

    Posted Nov 14, 2013 10:49 PM

    The VM I'm using to host the web client is the vCenter Server Appliance 5.5a that VMware provides as a downloadable OVF/OVA file. It's an SLES 11 image with 2 vCPUs and 8 GB of RAM.



  • 6.  RE: Very slow performance with the vSphere Web Client

    Posted Nov 14, 2013 11:02 PM

    Ah, I havent used the VC appliance recently, let alone the 5.5a rev.

    Im curious if you can install VC onto a VM on the 5.5 version and see if it responds better. We are seeing some slowness, but in the order of maybe a second per click. Not a minute.



  • 7.  RE: Very slow performance with the vSphere Web Client

    Posted Jan 08, 2014 06:57 PM

    I deployed this at a client as it it required for some features.  I also found it unusable.  Host 4 proc, 24 gig ram 2.66ghz



  • 8.  RE: Very slow performance with the vSphere Web Client

    Posted Jan 16, 2014 04:18 AM

    I am in fact going to open a ticket with GSS about this. Deployed 5.5 in customer environment, vCenter server is a Windows VM, specs 4vCPU, 24GB RAM. Environment around 80 ESXi hosts. Web client is unusable. You can navigate around for some time but then it will just hangs without any error. Have tried different browsers, even tweaked the flash config per William Lam's site (virtuallyghetto).



  • 9.  RE: Very slow performance with the vSphere Web Client
    Best Answer

    Posted Jan 21, 2014 05:44 AM

    The following changes improved the web client performance in my customer. So far no more hanged tasks, navigating the web client console was improved. We are still monitoring though.

    Increased the JVM heap size of  vSphere Web Client to 3GB. Used the following KB VMware KB: Configuring Tomcat server settings in VMware vCenter Server 5.1 and 5.5



  • 10.  RE: Very slow performance with the vSphere Web Client

    Posted Jun 02, 2014 08:15 PM

    Hello,

    In the link you provided (and I realize this is a VMware provided post in the link), I cannot find the directory/file listed for changing the web client JVM Heap Size:

    vSphere Web Client

    Configuration file location:

    installation_directory\Program Files\VMware\Infrastructure\vSphereWebClient\server\bin\service\conf\wrapper.conf

    I am running vCenter 5.5 on Windows but this directory does not exist.  When I get to the vShereWebClient directory, all I see is "DMServer" and "JRE" - not "Server".  And even under DMServer (thinking it was a typo in the article) there is no "bin" directory...only "config", "serenitydb", and "serviceability".

    Does anyone know the correct directory I should be looking in for the wrapper.conf file needed to change the vSphere Web Client heap size?

    Thanks

    NK



  • 11.  RE: Very slow performance with the vSphere Web Client

    Posted Jan 21, 2014 07:56 AM

    I was also facing the same the same issue . Than i installed the VMware-ClientIntegrationPlugin in to it. And its started responding 10x times faster.

    All the best,

    Anjani Kumar

    -----------------------------------------

    Please consider marking this answer "correct" or "helpful" if you found it useful.

    Anjani Kumar

    VMware, Windows

    Consulant

    Email ID : Anjani.kumar@vmwareminds.com

    Website : http://www.Vmwareminds.com



  • 12.  RE: Very slow performance with the vSphere Web Client

    Posted Jan 21, 2014 03:46 PM

    Installing the plugin was enough of an improvement to make it usable.  Thanks.  Still want to see if increasing the Heap also helps



  • 13.  RE: Very slow performance with the vSphere Web Client

    Posted Jan 21, 2014 05:22 PM

    Welcome buddy.


    Also appreciate marking answer "correct" or "helpful" so it can help others to fix their same issues..



    All the best,

    Anjani Kumar

    -----------------------------------------

    Please consider marking this answer "correct" or "helpful" if you found it useful.

    Anjani Kumar

    VMware, Windows

    Consulant

    Email ID : Anjani.kumar@vmwareminds.com

    Website : http://www.Vmwareminds.com




  • 14.  RE: Very slow performance with the vSphere Web Client

    Posted Jan 21, 2014 05:35 PM

    Tried but it someone else owns the thread so that is not an option

    Steve Desrosier

    TSG Consulting



  • 15.  RE: Very slow performance with the vSphere Web Client

    Posted Feb 23, 2024 12:34 PM

    Hi, we appear to heva an issue when monitoring VMs , but only when screen lock is apllied, there appears to be a rise in CPU useage , any thoughts please