vSphere Storage Appliance

 View Only
  • 1.  verifying q depth of HBA

    Posted Feb 29, 2016 07:41 PM

    Following the instructions in KB 1267:  VMware KB: Changing the queue depth for QLogic, Emulex, and Brocade HBAs  the command strings to change the queue LUN queue depth of the HBA listed, along with the string to verify your changes.

    When attempting to verify recent changes to the queue depth using the command I am turning up nothing but blank values in the output.

    Here is cut and paste from KB:

    Run this command to confirm that your changes have been applied:

    # esxcli system module parameters list -m driver

    Where driver is your QLogic, Emulex, or Brocade adapter driver module, such as lpfc820, qla2xxx, or bfa.

    The output appears similar to:

    Name                        Type  Value  Description
    --------------------------  ----  -----  --------------------------------------------------
    ql2xmaxqdepth               int   64     Maximum queue depth to report for target devices.

    HOWEVER - I'm not getting values returned, the example in the KB shows 64, but when I run the command on my hosts it is blank.

    Is this a new bug?  does anyone know an alternate way to retrieve the values?

  • 2.  RE: verifying q depth of HBA
    Best Answer

    Posted Feb 29, 2016 11:55 PM


    Most likely you don't see any outuput, could be due to INBOX drivers.


    Run this command and check the value in Device queue depth = 0x40 which will be HEX value


    /usr/lib/vmware/vmkmgmt_keyval/vmkmgmt_keyval -a


  • 3.  RE: verifying q depth of HBA

    Posted Mar 04, 2016 02:54 PM

    Thanks for your reply.   For some reason I did not receive an email notification when you posted your reply.. but I logged in this morning and saw it.

    FYI - I did open a ticket with VMware on this and they said that the command esxcli system module parameters list -m driver from KB1267 would no longer work.

    Thanks for the solution, the output for this command is loaded with good info. 

  • 4.  RE: verifying q depth of HBA

    Posted Mar 04, 2016 02:59 PM

    Also, this command is not found in my 5.0 build, but worked fine in 5.5, do not have a 5.1 build in my environment.