Backup & Recovery

 View Only
  • 1.  VDP - Reinstall of Appliance Issues

    Posted Oct 02, 2012 04:41 PM


    During my initial installation of VDP using the local admin account everything worked without a hitch.

    Why i reinstalled the appliance was that i initially tried to change the user that authenticates to the VC from the VDP appliance was to use a lesser powerful user account. The VDP stopped working, and i tried to switch back to the original admin account with no luck.

    So I reinstalled the appliances using the same dns names for each appliance. Everything is setup and all the checks are a go, but the backup jobs immediately failed everytime.

    I feel that there are hooks in the system where something is disassociated from the reinstalled appliances. Maybe somewhere in the Vcenter DB, SSO, etc?

    Could someone assist with a step by step clean uninstall of VDP which i hope will resolve the issue,

    Thank you


  • 2.  RE: VDP - Reinstall of Appliance Issues

    Broadcom Employee
    Posted Oct 03, 2012 04:44 AM

    Clean steps for VDP uninstall

    1. Power off & delete the appliance

    2. But you'll still see VDP plugin in the UI, So unregister the VDP plugin through the vcenter object browser(MOB)

    In your vCenter, open object browser - https://<ip of your vcenter>/mob

    Once prompted, provide the vcenter credentails

    Click on content

    Click on the extensionmanager

    You should see some extension with vdp (eg:- com.vmware.vdp) or similar

    clcik on unrgisterextension method and enter "com.vmware.vpd" or whatever you see in the above step

    click on Invoke method.

    You are done !

    Restart the web client service and you are all set.

    Go to UI and you will not find 'vSphere Data Protection' listed there.

    3. Now you start with a fresh install

  • 3.  RE: VDP - Reinstall of Appliance Issues

    Posted Oct 03, 2012 05:13 PM

    Thank you Suresh!

    BTW where did you learn how to do this? What is the reference you learned this from?

    Thank you.


  • 4.  RE: VDP - Reinstall of Appliance Issues

    Broadcom Employee
    Posted Oct 03, 2012 05:22 PM

    Traditionally most of the UI plugins for vsphere are registered in that path

  • 5.  RE: VDP - Reinstall of Appliance Issues

    Posted Oct 09, 2012 08:24 PM

    Well, the official vmware solution to my issue was the following KB.

    Thanks Ken and the engineers for the solution :smileyhappy:

    If your symptoms are the following - try the KB

    • vSphere Data Protection (VDP) deploys and configures successfully, but fails to start backup jobs
    • You do not see any errors
    • Agent logs indicate that no jobs are being picked up