Automation

 View Only
  • 1.  vCheck asking for credentials with vCenter Appliance

    Posted Apr 30, 2015 06:16 AM

    Hello,

    I am currently building a new environment using vSphere 6.

    I installed a vCenter Appliance 6.

    I want to use my good old daily vCheck from Alan Renouf (latest version available).

    When I run it against my new vCenter Appliance 6 it keeps asking me for my credentials...

    I tried to use the same script to run it against my "old" Windows vCenter 5.5 and it doesn't ask me for credentials.

    This is problematic as I want to schedule the vCheck...

    vCenter Appliance is joined to active directory, AD authentification is working correctly.

    FQDN is correctly set.

    I am using PowerCLI 6 Release 1.

    Thanks in advance for your help!



  • 2.  RE: vCheck asking for credentials with vCenter Appliance

    Posted May 06, 2015 05:55 AM

    Does someone has an idea?



  • 3.  RE: vCheck asking for credentials with vCenter Appliance

    Posted May 06, 2015 10:43 PM

    vCheck should work fine with the VCSA- definitely the 5.5 appliance works as I use it myself. I'm in no rush to move to 6.0 though, so someone may be able to comment on that.

    One thing to check would be your SSO config- I found that if you use AD as an LDAP server then passthrough didn't always work. Also, I *think* that it needed to be set as the default identity source.



  • 4.  RE: vCheck asking for credentials with vCenter Appliance

    Posted Jun 09, 2015 01:57 PM

    Hello!

    I didn't update as I was on holiday...

    My identity source is Active Directory (Integrated Windows Authentication) - use machine account

    I tried to set it as default as you suggested but still the same problem...

    Any other idea?

    Thanks for your help!



  • 5.  RE: vCheck asking for credentials with vCenter Appliance

    Posted Jun 11, 2015 06:14 AM

    There was an issue raised for this on Github:

    vCheck asking for credentials with vCenter Appliance · Issue #394 · alanrenouf/vCheck-vSphere · GitHub

    It appears that vCheck is not the problem, as running Connect-VIServer results in the same issue.



  • 6.  RE: vCheck asking for credentials with vCenter Appliance
    Best Answer

    Posted Jun 11, 2015 11:34 AM

    I found what was causing my problem...

    I applied the resolution from this KB:

    VMware KB: Logging in to the vCenter Server Appliance as vSphere Client users using the Use Windows session credenti…

    And now it works :-)



  • 7.  RE: vCheck asking for credentials with vCenter Appliance

    Posted Feb 25, 2016 03:15 PM

    Thanks, it actually helped me resolve the exact same issue.

    Henry.



  • 8.  RE: vCheck asking for credentials with vCenter Appliance

    Posted Mar 31, 2017 10:26 AM

    Hello, do you know what the fix was as it looks like the link is no longer working.

    Thanks