Flings

 View Only
  • 1.  VCF Inspector - requires manual config?

    Posted 29 days ago

    I'm trying the new VCF Inspector, but I get this error when trying to connect the first time (brand new VCF setup):

    SSH connection succeeded but kubectl is not accessible on this host. Ensure the SSH user has sudo privileges and /etc/kubernetes/admin.conf exists on the node.

    I'll continue to investigate these errors, but just a heads up if anyone else decides to try it out (and if anyone has a quick fix, please let me know!).



  • 2.  RE: VCF Inspector - requires manual config?

    Posted 29 days ago

    Upon investigation, /etc/kubernetes/admin.conf is missing on my VCF Service Runtime control node, will open a support case to see if this is a known issue.




  • 3.  RE: VCF Inspector - requires manual config?

    Broadcom Employee
    Posted 26 days ago

    I will point Alan to your post. He'll reply soon.




  • 4.  RE: VCF Inspector - requires manual config?

    Posted 26 days ago

    Thanks, I've opened a support case as well with a scheduled call for tomorrow, so hopefully I'll have some more info about why it's missing




  • 5.  RE: VCF Inspector - requires manual config?
    Best Answer

    Posted 25 days ago

    I will reply to my own message here. This problem was based on a misunderstanding from my part, due to the fact that 'VCF services runtime FQDN' is pointing towards the worker nodes and not the control plane nodes. Finding out a Control Plane Node IP via VCF Ops and using that for the fling worked much better.

    So, error on my part for not reading exploring the helpful tip on the fling and assuming I could use the FQDN for a more persistant use :)




  • 6.  RE: VCF Inspector - requires manual config?

    Broadcom Employee
    Posted 22 days ago

    Just got back from PTO, was going to say make sure you were connecting to the Control Plane node ;) Glad you resolved this.