ESXi

 View Only
Expand all | Collapse all

vCenter Server is not working After p2v

  • 1.  vCenter Server is not working After p2v

    Posted Jan 10, 2013 02:04 PM

    Hi,

    I have installed vCenter server 5.1 in one physical machine. Using vCenter converter I am taking backup of my vCenter server. It is working ok. But after p2v when I start my virtual machine, vCenter server is not working even ODBC conncection is fine.

    Can anybody suggest that any setting I need to do for that.

    Thanks



  • 2.  RE: vCenter Server is not working After p2v

    Posted Jan 10, 2013 02:08 PM

    Did you reconfigure the network settings after the conversion?

    Please provide some details about what's "not working". Any warnings or error messages (Windows Event Log) might help.

    André



  • 3.  RE: vCenter Server is not working After p2v

    Posted Jan 10, 2013 02:18 PM

    Yes I have reconfigured the network setting.

    Below Event I found in event log:

    The description for Event ID 1000 from source VMware VirtualCenter Server cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event:

    Forcing shutdown of VMware VirtualCenter now



  • 4.  RE: vCenter Server is not working After p2v

    Posted Jan 10, 2013 02:21 PM

    Logs:

    Section for VMware VirtualCenter, pid=3164, version=5.1.0, build=880146, option=Release

    ------ In-memory logs start --------
    mem> 2013-01-10T06:15:06.268-08:00 [03112 info 'Default'] Process attached
    mem> 2013-01-10T06:15:06.329-08:00 [03140 info 'Default'] Thread attached
    mem> 2013-01-10T06:15:06.329-08:00 [04104 info 'Default'] Thread attached
    mem> 2013-01-10T06:15:06.329-08:00 [01536 info 'Default'] Thread attached
    mem> 2013-01-10T06:15:06.329-08:00 [01536 info 'Hooks'] Hooks Initialized

    ------ In-memory logs end   --------
    2013-01-10T06:15:06.341-08:00 [01536 info 'Default'] Logging uses fast path: true
    2013-01-10T06:15:06.341-08:00 [01536 info 'Libs'] VThreadBase detected multiple threads.
    2013-01-10T06:15:06.341-08:00 [01536 info 'Default'] Handling bora/lib logs with VmaCore facilities
    2013-01-10T06:15:06.341-08:00 [01536 info 'Default'] Initialized channel manager
    2013-01-10T06:15:06.354-08:00 [01536 info 'Default'] Current working directory: C:\Windows\system32
    2013-01-10T06:15:06.354-08:00 [01536 info 'Default'] ThreadPool windowsStackImmediateCommit = true
    2013-01-10T06:15:06.354-08:00 [01536 info 'ThreadPool'] Thread enlisted
    2013-01-10T06:15:06.354-08:00 [01536 info 'Default'] Log path: C:\ProgramData\VMware\VMware VirtualCenter\Logs
    2013-01-10T06:15:06.354-08:00 [01536 info 'Default'] Initializing SSL
    2013-01-10T06:15:07.384-08:00 [01536 info 'Default'] Vmacore::InitSSL: handshakeTimeoutUs = 120000000
    2013-01-10T06:15:07.384-08:00 [03252 info 'Default'] Thread attached
    2013-01-10T06:15:07.384-08:00 [03252 info 'ThreadPool'] Thread enlisted
    2013-01-10T06:15:07.386-08:00 [01536 info 'ThreadPool'] Thread enlisted
    2013-01-10T06:15:07.390-08:00 [01388 info 'Default'] Thread attached
    2013-01-10T06:15:07.394-08:00 [01536 info 'Default'] Starting VMware VirtualCenter 5.1.0 build-880146
    2013-01-10T06:15:07.394-08:00 [01536 info 'Default'] Log directory: C:\ProgramData\VMware\VMware VirtualCenter\Logs.
    2013-01-10T06:15:07.395-08:00 [01536 info 'vpxdvpxdMain'] Account name: Administrator
    2013-01-10T06:15:07.395-08:00 [01536 info 'win32vpxdOsLayer_win32'] Total virtual memory available for the process 8589934464 KB
    2013-01-10T06:15:07.395-08:00 [01536 info 'win32vpxdOsLayer_win32'] [VpxOsLayer] Enabled low-frag process heap.
    -->
    2013-01-10T06:15:07.395-08:00 [01536 info 'win32vpxdOsLayer_win32'] [VpxOsLayer] Enabled low-frag crt heap.
    -->
    2013-01-10T06:15:07.395-08:00 [04408 info 'Default'] Thread attached
    2013-01-10T06:15:07.395-08:00 [04408 info 'ThreadPool'] Thread enlisted
    2013-01-10T06:15:07.395-08:00 [01536 info 'commonvpxLro'] [VpxLRO] 640 max LROs
    2013-01-10T06:15:07.395-08:00 [01536 info 'commonvpxLro'] [VpxLRO] 12 reserved internal LROs
    2013-01-10T06:15:07.395-08:00 [01536 info 'commonvpxLro'] [VpxLRO] 12 reserved blocker LROs
    2013-01-10T06:15:07.395-08:00 [01536 info 'commonvpxLro'] [VpxLRO] 12 reserved short LROs
    2013-01-10T06:15:07.395-08:00 [01536 info 'commonvpxLro'] [VpxLRO] 8 reserved long LROs
    2013-01-10T06:15:07.395-08:00 [01536 info 'commonvpxLro'] [VpxLRO] 600-second completed task lifetime
    2013-01-10T06:15:07.395-08:00 [01536 info 'commonvpxLro'] [VpxLRO] 60-second minimum completed task lifetime
    2013-01-10T06:15:07.395-08:00 [01536 info 'commonvpxLro'] [VpxLRO] 200 maximum completed tasks
    2013-01-10T06:15:07.395-08:00 [01536 info 'commonvpxLro'] [VpxLRO] 600-second unregistered task lifetime
    2013-01-10T06:15:07.396-08:00 [03648 info 'Default'] Thread attached
    2013-01-10T06:15:07.396-08:00 [03648 info 'ThreadPool'] Thread enlisted
    2013-01-10T06:15:07.397-08:00 [01536 info 'utilvpxdVdb'] Registry Item DB 5 value is '50'
    2013-01-10T06:15:07.397-08:00 [01536 info 'utilvpxdVdb'] [VpxdVdb::SetDBType] Logging in to DSN: vcenterdb with username vpxuser
    2013-01-10T06:15:07.409-08:00 [01040 info 'Default'] Thread attached
    2013-01-10T06:15:07.421-08:00 [01040 info 'Default'] Thread detached
    2013-01-10T06:15:07.428-08:00 [02688 info 'Default'] Thread attached
    2013-01-10T06:15:07.490-08:00 [01536 info 'Default'] [VdbSchemaLoader::LookupSchemaFromDB] Loaded schema and index information from DB
    2013-01-10T06:15:07.503-08:00 [01536 info 'utilvpxdDbSchemaHash'] [VpxdDbSchemaHash::GetSchemaFilename]: sqlDir: C:\Program Files\VMware\Infrastructure\VirtualCenter Server\sql\
    2013-01-10T06:15:07.503-08:00 [01536 info 'utilvpxdDbSchemaHash'] [VpxdDbSchemaHash::CheckSchema]: schema file: C:\Program Files\VMware\Infrastructure\VirtualCenter Server\sql\VCDB_mssql.sql
    2013-01-10T06:15:07.507-08:00 [00508 info 'Default'] Thread attached
    2013-01-10T06:15:07.507-08:00 [00508 info 'ThreadPool'] Thread enlisted
    2013-01-10T06:15:07.507-08:00 [01536 info 'win32vpxLdapBackup_win32'] [LdapBackup] Making sure LDAP instance VMwareVCMSDS is running
    2013-01-10T06:15:07.507-08:00 [01536 info 'win32vpxLdapBackup_win32'] [LdapBackup] Attempting to start service ADAM_VMwareVCMSDS...
    2013-01-10T06:15:07.507-08:00 [01536 info 'win32vpxLdapBackup_win32'] [LdapBackup] Service stopped, starting
    2013-01-10T06:15:19.396-08:00 [04408 warning 'VpxProfiler' opID=SWI-81764c] VpxUtil_InvokeWithOpId [TotalTime] took 12000 ms
    2013-01-10T06:15:31.396-08:00 [04408 warning 'VpxProfiler' opID=SWI-10e99a5a] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms
    2013-01-10T06:15:43.397-08:00 [04408 warning 'VpxProfiler' opID=SWI-d21e8f76] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms
    2013-01-10T06:15:55.398-08:00 [04408 warning 'VpxProfiler' opID=SWI-d870ab66] VpxUtil_InvokeWithOpId [TotalTime] took 12000 ms
    2013-01-10T06:16:07.398-08:00 [04408 warning 'VpxProfiler' opID=SWI-8639911b] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms
    2013-01-10T06:16:13.330-08:00 [03140 info 'Default'] Thread detached
    2013-01-10T06:16:19.399-08:00 [04408 warning 'VpxProfiler' opID=SWI-ede2901c] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms
    2013-01-10T06:16:31.400-08:00 [04408 warning 'VpxProfiler' opID=SWI-15ec49c8] VpxUtil_InvokeWithOpId [TotalTime] took 12000 ms
    2013-01-10T06:16:36.328-08:00 [04480 info 'Default'] Thread attached
    2013-01-10T06:16:36.328-08:00 [01784 info 'Default'] Thread attached
    2013-01-10T06:16:43.400-08:00 [04408 warning 'VpxProfiler' opID=SWI-e856fe2d] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms
    2013-01-10T06:16:55.401-08:00 [04408 warning 'VpxProfiler' opID=SWI-f555343e] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms
    2013-01-10T06:17:07.402-08:00 [04408 warning 'VpxProfiler' opID=SWI-7d60e0ea] VpxUtil_InvokeWithOpId [TotalTime] took 12000 ms
    2013-01-10T06:17:19.402-08:00 [04408 warning 'VpxProfiler' opID=SWI-ac0ecfd3] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms
    2013-01-10T06:17:31.404-08:00 [04408 warning 'VpxProfiler' opID=SWI-3a2f669c] VpxUtil_InvokeWithOpId [TotalTime] took 12002 ms
    2013-01-10T06:17:43.329-08:00 [01784 info 'Default'] Thread detached
    2013-01-10T06:17:43.329-08:00 [04480 info 'Default'] Thread detached
    2013-01-10T06:17:43.405-08:00 [04408 warning 'VpxProfiler' opID=SWI-d59fc45c] VpxUtil_InvokeWithOpId [TotalTime] took 12000 ms
    2013-01-10T06:17:55.405-08:00 [04408 warning 'VpxProfiler' opID=SWI-b999848e] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms
    2013-01-10T06:18:06.328-08:00 [04420 info 'Default'] Thread attached
    2013-01-10T06:18:06.328-08:00 [03980 info 'Default'] Thread attached
    2013-01-10T06:18:07.406-08:00 [04408 warning 'VpxProfiler' opID=SWI-bb305a87] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms
    2013-01-10T06:18:19.407-08:00 [04408 warning 'VpxProfiler' opID=SWI-9ea3c26b] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms
    2013-01-10T06:18:31.408-08:00 [04408 warning 'VpxProfiler' opID=SWI-4548344b] VpxUtil_InvokeWithOpId [TotalTime] took 12000 ms
    2013-01-10T06:18:43.408-08:00 [04408 warning 'VpxProfiler' opID=SWI-e23ba4f3] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms
    2013-01-10T06:18:55.409-08:00 [04408 warning 'VpxProfiler' opID=SWI-7087954f] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms
    2013-01-10T06:19:07.411-08:00 [04408 warning 'VpxProfiler' opID=SWI-78983a28] VpxUtil_InvokeWithOpId [TotalTime] took 12000 ms
    2013-01-10T06:19:13.329-08:00 [03980 info 'Default'] Thread detached
    2013-01-10T06:19:13.329-08:00 [04420 info 'Default'] Thread detached
    2013-01-10T06:19:19.411-08:00 [04408 warning 'VpxProfiler' opID=SWI-53c25362] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms
    2013-01-10T06:19:31.413-08:00 [04408 warning 'VpxProfiler' opID=SWI-70d332b2] VpxUtil_InvokeWithOpId [TotalTime] took 12002 ms
    2013-01-10T06:19:43.414-08:00 [04408 warning 'VpxProfiler' opID=SWI-d891e7b8] VpxUtil_InvokeWithOpId [TotalTime] took 12000 ms
    2013-01-10T06:19:55.414-08:00 [04408 warning 'VpxProfiler' opID=SWI-64623610] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms



  • 5.  RE: vCenter Server is not working After p2v

    Posted Jan 10, 2013 02:26 PM

    Hi,

    First can you try restarting vCenter server serivce from Service manager. Then get latest vpxd.log from C:\ProgramData\VMware\VMware VirtualCenter\Logs

    In belows log , there is no much information to proceed further.

    Regards

    MOhammed



  • 6.  RE: vCenter Server is not working After p2v

    Posted Jan 10, 2013 02:34 PM

    Updated Log:

    ------ In-memory logs start --------

    mem> 2013-01-10T06:30:51.147-08:00 [02988 info 'Default'] Process attached

    mem> 2013-01-10T06:30:51.208-08:00 [02988 info 'Hooks'] Hooks Initialized

    ------ In-memory logs end   --------

    2013-01-10T06:30:51.219-08:00 [02988 info 'Default'] Logging uses fast path: true

    2013-01-10T06:30:51.219-08:00 [02988 info 'Default'] Handling bora/lib logs with VmaCore facilities

    2013-01-10T06:30:51.219-08:00 [02988 info 'Default'] Initialized channel manager

    2013-01-10T06:30:51.227-08:00 [02988 info 'Default'] Current working directory: C:\Program Files\VMware\Infrastructure\VirtualCenter Server

    2013-01-10T06:30:51.227-08:00 [02988 info 'Default'] ThreadPool windowsStackImmediateCommit = true

    2013-01-10T06:30:51.227-08:00 [02988 info 'ThreadPool'] Thread enlisted

    2013-01-10T06:30:51.228-08:00 [02988 info 'Default'] Log path: C:\ProgramData\VMware\VMware VirtualCenter\Logs

    2013-01-10T06:30:51.228-08:00 [02988 info 'Default'] Initializing SSL

    2013-01-10T06:30:51.233-08:00 [04616 info 'Default'] Thread attached

    2013-01-10T06:30:52.262-08:00 [02988 info 'Default'] Vmacore::InitSSL: handshakeTimeoutUs = 120000000

    2013-01-10T06:30:52.263-08:00 [04144 info 'Default'] Thread attached

    2013-01-10T06:30:52.263-08:00 [04144 info 'ThreadPool'] Thread enlisted

    2013-01-10T06:30:52.269-08:00 [04576 info 'Default'] Thread attached

    2013-01-10T06:30:52.273-08:00 [02988 info 'Default'] Starting VMware VirtualCenter 5.1.0 build-880146

    2013-01-10T06:30:52.273-08:00 [02988 info 'Default'] Log directory: C:\ProgramData\VMware\VMware VirtualCenter\Logs.

    2013-01-10T06:30:52.274-08:00 [02988 info 'vpxdvpxdMain'] Account name: Administrator

    2013-01-10T06:30:52.274-08:00 [02988 info 'win32vpxdOsLayer_win32'] Total virtual memory available for the process 8589934464 KB

    2013-01-10T06:30:52.274-08:00 [02988 info 'win32vpxdOsLayer_win32'] [VpxOsLayer] Enabled low-frag process heap.

    -->

    2013-01-10T06:30:52.274-08:00 [02988 info 'win32vpxdOsLayer_win32'] [VpxOsLayer] Enabled low-frag crt heap.

    -->

    2013-01-10T06:30:52.274-08:00 [04680 info 'Default'] Thread attached

    2013-01-10T06:30:52.274-08:00 [04680 info 'ThreadPool'] Thread enlisted

    2013-01-10T06:30:52.274-08:00 [02988 info 'commonvpxLro'] [VpxLRO] 640 max LROs

    2013-01-10T06:30:52.274-08:00 [02988 info 'commonvpxLro'] [VpxLRO] 12 reserved internal LROs

    2013-01-10T06:30:52.274-08:00 [02988 info 'commonvpxLro'] [VpxLRO] 12 reserved blocker LROs

    2013-01-10T06:30:52.274-08:00 [02988 info 'commonvpxLro'] [VpxLRO] 12 reserved short LROs

    2013-01-10T06:30:52.274-08:00 [02988 info 'commonvpxLro'] [VpxLRO] 8 reserved long LROs

    2013-01-10T06:30:52.274-08:00 [02988 info 'commonvpxLro'] [VpxLRO] 600-second completed task lifetime

    2013-01-10T06:30:52.274-08:00 [02988 info 'commonvpxLro'] [VpxLRO] 60-second minimum completed task lifetime

    2013-01-10T06:30:52.274-08:00 [02988 info 'commonvpxLro'] [VpxLRO] 200 maximum completed tasks

    2013-01-10T06:30:52.274-08:00 [02988 info 'commonvpxLro'] [VpxLRO] 600-second unregistered task lifetime

    2013-01-10T06:30:52.275-08:00 [02656 info 'Default'] Thread attached

    2013-01-10T06:30:52.275-08:00 [02656 info 'ThreadPool'] Thread enlisted

    2013-01-10T06:30:52.275-08:00 [02988 info 'utilvpxdVdb'] Registry Item DB 5 value is '50'

    2013-01-10T06:30:52.276-08:00 [02988 info 'utilvpxdVdb'] [VpxdVdb::SetDBType] Logging in to DSN: vcenterdb with username vpxuser

    2013-01-10T06:30:52.289-08:00 [04672 info 'Default'] Thread attached

    2013-01-10T06:30:52.293-08:00 [04672 info 'Default'] Thread detached

    2013-01-10T06:30:52.300-08:00 [04604 info 'Default'] Thread attached

    2013-01-10T06:31:04.275-08:00 [04680 warning 'VpxProfiler' opID=SWI-bca84821] VpxUtil_InvokeWithOpId [TotalTime] took 12000 ms

    2013-01-10T06:31:04.275-08:00 [03596 info 'Default'] Thread attached

    2013-01-10T06:31:04.275-08:00 [03596 info 'ThreadPool'] Thread enlisted

    2013-01-10T06:31:16.275-08:00 [04680 warning 'VpxProfiler' opID=SWI-b2d2567] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms

    2013-01-10T06:31:28.276-08:00 [04680 warning 'VpxProfiler' opID=SWI-f744d97b] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms

    2013-01-10T06:31:40.277-08:00 [04680 warning 'VpxProfiler' opID=SWI-4c2f7d33] VpxUtil_InvokeWithOpId [TotalTime] took 12000 ms

    2013-01-10T06:31:52.277-08:00 [04680 warning 'VpxProfiler' opID=SWI-a49a8fdd] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms

    2013-01-10T06:31:52.390-08:00 [02988 error 'Default'] [Vdb::LockRepositoryHelper] SQLExecDirect failed: HYT00:0:ODBC error: (HYT00) - [Microsoft][SQL Server Native Client 10.0]Query timeout expired

    2013-01-10T06:31:52.390-08:00 [02988 error 'Default'] Unable to get exclusive access to vCenter repository.                           Please check if another vCenter instance is                           running against the same database schema.

    2013-01-10T06:31:52.391-08:00 [04604 info 'Default'] Thread detached

    2013-01-10T06:31:52.391-08:00 [02988 warning 'VpxProfiler'] Vpxd::ServerApp::Init [VpxdVdb::Init(VpxdVdb::GetVcVdbInstId(), false, false, NULL)] took 60116 ms

    2013-01-10T06:31:52.391-08:00 [02988 error 'vpxdvpxdMain'] [Vpxd::ServerApp::Init] Init failed: VpxdVdb::Init(VpxdVdb::GetVcVdbInstId(), false, false, NULL)

    --> Backtrace:

    --> backtrace[00] rip 000000018018a8ca

    --> backtrace[01] rip 0000000180102f28

    --> backtrace[02] rip 000000018010423e

    --> backtrace[03] rip 000000018008e00b

    --> backtrace[04] rip 0000000000455c2c

    --> backtrace[05] rip 0000000000476512

    --> backtrace[06] rip 0000000140149b7c

    --> backtrace[07] rip 000000014014859c

    --> backtrace[08] rip 000000014036aa3d

    --> backtrace[09] rip 000000014036ae8f

    --> backtrace[10] rip 0000000140a584e2

    --> backtrace[11] rip 0000000076d6f56d

    --> backtrace[12] rip 0000000076fa3281

    -->

    2013-01-10T06:31:52.394-08:00 [02988 warning 'VpxProfiler'] ServerApp::Init [TotalTime] took 60120 ms

    2013-01-10T06:31:52.394-08:00 [02988 error 'Default'] Failed to intialize VMware VirtualCenter. Shutting down...

    2013-01-10T06:31:52.396-08:00 [02988 info 'vpxdvpxdSupportManager'] Wrote uptime information

    2013-01-10T06:31:52.410-08:00 [02988 error 'Default'] Alert:false@ d:/build/ob/bora-880146/bora/vpx/vpxd/util/vdb.cpp:422

    --> Backtrace:

    --> backtrace[00] rip 000000018018a8ca

    --> backtrace[01] rip 0000000180102f28

    --> backtrace[02] rip 000000018010423e

    --> backtrace[03] rip 000000018009a09a

    --> backtrace[04] rip 000000013f903bd9

    --> backtrace[05] rip 0000000140147b22

    --> backtrace[06] rip 00000001401485da

    --> backtrace[07] rip 000000014036aa3d

    --> backtrace[08] rip 000000014036ae8f

    --> backtrace[09] rip 0000000140a584e2

    --> backtrace[10] rip 0000000076d6f56d

    --> backtrace[11] rip 0000000076fa3281

    -->

    2013-01-10T06:31:52.410-08:00 [02988 info 'utilvpxdVdb'] Registry Item DB 5 value is '50'

    2013-01-10T06:31:52.410-08:00 [02988 info 'utilvpxdVdb'] [VpxdVdb::SetDBType] Logging in to DSN: vcenterdb with username vpxuser

    2013-01-10T06:31:52.418-08:00 [04240 info 'Default'] Thread attached

    2013-01-10T06:31:52.420-08:00 [04240 info 'Default'] Thread detached

    2013-01-10T06:31:52.428-08:00 [03640 info 'Default'] Thread attached

    2013-01-10T06:32:04.278-08:00 [04680 warning 'VpxProfiler' opID=SWI-c413ac5b] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms

    2013-01-10T06:32:16.279-08:00 [02656 warning 'VpxProfiler' opID=SWI-924412c2] VpxUtil_InvokeWithOpId [TotalTime] took 12000 ms

    2013-01-10T06:32:21.208-08:00 [02360 info 'Default'] Thread attached

    2013-01-10T06:32:21.208-08:00 [02020 info 'Default'] Thread attached

    2013-01-10T06:32:28.279-08:00 [04680 warning 'VpxProfiler' opID=SWI-bdeae59d] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms

    2013-01-10T06:32:40.280-08:00 [04680 warning 'VpxProfiler' opID=SWI-da796808] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms

    2013-01-10T06:32:52.281-08:00 [04680 warning 'VpxProfiler' opID=SWI-55390109] VpxUtil_InvokeWithOpId [TotalTime] took 12000 ms

    2013-01-10T06:32:52.478-08:00 [02988 error 'Default'] [Vdb::LockRepositoryHelper] SQLExecDirect failed: HYT00:0:ODBC error: (HYT00) - [Microsoft][SQL Server Native Client 10.0]Query timeout expired

    2013-01-10T06:32:52.479-08:00 [02988 error 'Default'] Unable to get exclusive access to vCenter repository.                           Please check if another vCenter instance is                           running against the same database schema.

    2013-01-10T06:32:52.480-08:00 [03640 info 'Default'] Thread detached

    2013-01-10T06:32:52.498-08:00 [02988 warning 'vpxdvpxdMain'] Database not initialized. Nothing to unlock

    2013-01-10T06:32:52.499-08:00 [02988 info 'Default'] Forcing shutdown of VMware VirtualCenter now



  • 7.  RE: vCenter Server is not working After p2v

    Posted Jan 10, 2013 02:39 PM

    2013-01-10T06:32:52.479-08:00 [02988 error 'Default'] Unable to get  exclusive access to vCenter repository.                           Please  check if another vCenter instance is                           running  against the same database schema.

    Check the below KB for the above error message

    http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1006369

    http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1007322



  • 8.  RE: vCenter Server is not working After p2v

    Posted Jan 10, 2013 02:48 PM

    Hi,

    Is vCenter server database is on same machine or remote machine, from logs it says that older lock on vCenter server database is not released.

    Regards

    Mohammed



  • 9.  RE: vCenter Server is not working After p2v

    Posted Jan 10, 2013 02:51 PM

    Hi,

    Database is on same machine. Database is "SQL Server2008 R2 standard".



  • 10.  RE: vCenter Server is not working After p2v

    Posted Jan 10, 2013 03:01 PM

    I belive the KB 1006369 also applies to SQL.. Try to restart the DB services and bring up the vCenter service and see if it start fine..

    Make sure you have the VUM serives before you perform the task



  • 11.  RE: vCenter Server is not working After p2v

    Posted Jan 11, 2013 07:29 AM

    Hi,

    Update manager service I can not see in windows services. still problem is there. Any other solution plz.



  • 12.  RE: vCenter Server is not working After p2v

    Posted Jan 16, 2013 02:57 PM

    I have the same problem.

    Separate SSO server

    2 Separate vCenter servers

    Seperate SQL server hosting 2 databases for the vCenter servers

    no update manager on the failing vCenter

    error:

    Unable to get exclusive access to vCenter repository. Please check if another vCenter instance is running against the same database schema.



  • 13.  RE: vCenter Server is not working After p2v

    Posted Jan 10, 2013 02:52 PM

    Hi,

    As aravind mention, this KB might help you

    http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1007322

    other Kb will not work since it is for Oracle DB.

    Regards

    Mohammed