View Only

vCenter Server Appliance is denying all inbound traffic

  • 1.  vCenter Server Appliance is denying all inbound traffic

    Posted Nov 21, 2016 09:34 PM


    This morning I found that our vCenter Server Appliance is not responding. Once connected to the ESXi host I discovered that appliance itself is up and running. I opened console and logged in to the BASH shell. There I ran ifconfig and saw that the network interface is up and has correct IP. At this point I decided to restart the box. However, restart didn't resolve the problem: I am still not able to reach the appliance. From the BASH shell I verified that I can ping gateway and other boxes on the network. I also opened ssh session to one of the Linux boxes. So, it seems that outbound traffic is not restricted whereas all inbound traffic is denied. I tried to stop firewall on the appliance to see if the problem is with firewall. And here is my problem. I don't know how to stop or disable the firewall on the vCenter appliance through the console access. And since the inbound traffic is denied I can't use esxcli. The only avenue is through the console.

    In BASH shell I have not seen iptables and firewall in /etc/init.d/. There is no services named firewall or something like this to that matter. I have a feeling that it may be a child process from the network service but I can't find anywhere how to control it over command line. Also there is no com.vmware.appliance.version1.networking.firewall stop or something like this.

    I will highly appreciate any help stopping or disabling firewall.