vCenter

 View Only
  • 1.  Unknown error returned by wmware converter agent

    Posted Feb 19, 2007 02:56 PM

    I made a lot of convertion trials and 50 - 70% fails.

    I read a lot of the error messages in this forum. But nobody has a good solution. I copy and paste the log file entrys to this forum and hope that we can discuss together the errors. Hopefully someone from VMware was read this stuff and can support us.

    Thanks

    Olaf Wiegmann

    Log for VMware Converter, pid=1712, version=3.0.0, build=build-39557, option=Release, section=2

    \[2007-02-19 12:28:00.296 'App' 268 verbose] \[imageProcessingTaskStep,307] VmiImportTask::task\{4} step "Clone VM" 100% completed

    \[#2] \[2007-02-19 12:28:00.296 'App' 288 verbose] \[imageProcessingTaskWrapper,437] Waiting for updates from CloneTask::task\{5}

    \[#2] \[2007-02-19 12:28:00.296 'App' 288 verbose] \[imageProcessingTaskWrapper,668] (Re)Start waiting for property updates from CloneTask::task\{5}

    \[2007-02-19 12:28:00.296 'App' 1488 verbose] \[imageProcessingTaskWrapper,749] Got an update from BlockLevelCloning::task\{6}

    \[#2] \[2007-02-19 12:28:00.296 'App' 1628 verbose] \[imageProcessingTaskWrapper,437] Waiting for updates from BlockLevelCloning::task\{6}

    \[#2] \[2007-02-19 12:28:00.296 'App' 1628 verbose] \[imageProcessingTaskWrapper,668] (Re)Start waiting for property updates from BlockLevelCloning::task\{6}

    \[2007-02-19 12:28:00.296 'App' 400 verbose] \[imageProcessingTaskWrapper,749] Got an update from CloneTask::task\{5}

    \[#2] \[2007-02-19 12:28:00.296 'App' 288 verbose] \[imageProcessingTaskWrapper,437] Waiting for updates from CloneTask::task\{5}

    \[#2] \[2007-02-19 12:28:00.296 'App' 288 verbose] \[imageProcessingTaskWrapper,668] (Re)Start waiting for property updates from CloneTask::task\{5}

    \[??] \[2007-02-19 12:38:06.328 'App' 1648 info] \[stub,42] NfcNetTcpWrite: timed out waiting for socket to be ready (101)

    \[??] \[2007-02-19 12:38:06.328 'App' 1648 info] \[stub,42] \[NFC ERROR] NfcNet_Send: requested 272, sent only 9 bytes

    \[??] \[2007-02-19 12:38:06.328 'App' 1648 info] \[stub,42] \[NFC ERROR] NfcFileSendMessage: hdr send failed:

    \[??] \[2007-02-19 12:38:06.328 'App' 1648 info] \[stub,42] \[NFC ERROR] NfcFile_Send: Something is messed up

    \[#2] \[2007-02-19 12:38:14.828 'App' 764 info] \[imageProcessingTaskStep,196] BlockLevelCloning::task\{6} step "copy local->remote" destroyed

    \[#2] \[2007-02-19 12:38:14.828 'App' 764 error] \[blockLevelCloningTaskImpl,820] File transfer failed.

    \[#2] Dst error: Network error -- Failed to send header message:

    \[#2] \[2007-02-19 12:39:14.328 'App' 764 error] \[imageProcessingTaskImpl,552] BlockLevelCloning::task\{6}: Image processing task has failed with MethodFault::Exception: sysimage.fault.NfcConnectionFault

    \[#2] \[2007-02-19 12:39:14.531 'App' 764 verbose] \[imageProcessingTaskImpl,154] BlockLevelCloning::task\{6}: SetState to error

    \[#2] \[2007-02-19 12:39:14.531 'App' 764 verbose] \[imageProcessingTaskWrapper,886] Remote task BlockLevelCloning::task\{6} completed

    \[#2] \[2007-02-19 12:39:14.531 'App' 1628 verbose] \[imageProcessingTaskWrapper,437] Waiting for updates from BlockLevelCloning::task\{6}

    \[2007-02-19 12:39:14.531 'App' 764 verbose] \[imageProcessingTaskWrapper,749] Got an update from BlockLevelCloning::task\{6}

    \[#2] \[2007-02-19 12:39:14.531 'App' 1628 verbose] \[imageProcessingTaskWrapper,515] Cleaning up remote task BlockLevelCloning::task\{6}

    \[2007-02-19 12:39:14.531 'App' 764 verbose] \[imageProcessingTaskWrapper,749] Got an update from CloneTask::task\{5}

    \[#2] \[2007-02-19 12:39:14.531 'App' 288 verbose] \[imageProcessingTaskWrapper,437] Waiting for updates from CloneTask::task\{5}

    \[#2] \[2007-02-19 12:39:14.531 'App' 288 verbose] \[imageProcessingTaskWrapper,668] (Re)Start waiting for property updates from CloneTask::task\{5}

    \[#2] \[2007-02-19 12:39:14.718 'App' 1628 verbose] \[imageProcessingTaskWrapper,1201] Disposing task wrapper for task BlockLevelCloning::task\{6}

    \[#2] \[2007-02-19 12:39:14.937 'App' 1924 verbose] \[disposable,121] object explicitly disposed: BlockLevelCloning::task\{6}

    \[#2] \[2007-02-19 12:39:15.031 'App' 1924 verbose] \[imageProcessingTaskImpl,123] BlockLevelCloning::task\{6} being destroyed

    \[#2] \[2007-02-19 12:39:15.078 'App' 1628 error] \[imageProcessingTaskStep,425] CloneTask::task\{5} step "Cloning into disk \[netapp] w2k3_ES_Ringmaster/w2k3_ES_Ringmaster.vmdk" failed

    \[#2] \[2007-02-19 12:39:15.078 'App' 1628 verbose] \[imageProcessingTaskWrapper,1117] Reporting image processing task failure for task BlockLevelCloning::task\{6}

    \[#2] \[2007-02-19 12:39:15.078 'App' 1628 error] \[imageProcessingTaskWrapper,1124] ImageProcessingTask FAILED. Fault name: sysimage.fault.NfcConnectionFault

    \[#2] \[2007-02-19 12:39:15.296 'App' 1628 info] \[imageProcessingTaskStep,196] CloneTask::task\{5} step "Cloning into disk \[netapp] w2k3_ES_Ringmaster/w2k3_ES_Ringmaster.vmdk" destroyed

    \[#2] \[2007-02-19 12:39:15.328 'App' 1628 info] \[imageProcessingTaskStep,196] CloneTask::task\{5} step "cloning target disks" destroyed

    \[#2] \[2007-02-19 12:39:15.328 'App' 1628 error] \[cloneTask,210] Cloning failed!

    \[#2] \[2007-02-19 12:39:15.343 'App' 1628 error] \[imageProcessingTaskImpl,552] CloneTask::task\{5}: Image processing task has failed with MethodFault::Exception: sysimage.fault.NfcConnectionFault

    \[#2] \[2007-02-19 12:39:15.343 'App' 1628 verbose] \[imageProcessingTaskImpl,154] CloneTask::task\{5}: SetState to error

    \[#2] \[2007-02-19 12:39:15.343 'App' 1628 verbose] \[imageProcessingTaskWrapper,886] Remote task CloneTask::task\{5} completed

    \[#2] \[2007-02-19 12:39:15.343 'App' 288 verbose] \[imageProcessingTaskWrapper,437] Waiting for updates from CloneTask::task\{5}

    \[2007-02-19 12:39:15.343 'App' 1628 verbose] \[imageProcessingTaskWrapper,749] Got an update from CloneTask::task\{5}

    \[#2] \[2007-02-19 12:39:15.343 'App' 288 verbose] \[imageProcessingTaskWrapper,515] Cleaning up remote task CloneTask::task\{5}

    \[#2] \[2007-02-19 12:39:15.343 'App' 288 verbose] \[imageProcessingTaskWrapper,1201] Disposing task wrapper for task CloneTask::task\{5}

    \[#2] \[2007-02-19 12:39:15.343 'App' 1924 verbose] \[disposable,121] object explicitly disposed: CloneTask::task\{5}

    \[#2] \[2007-02-19 12:39:15.718 'App' 1924 verbose] \[imageProcessingTaskImpl,123] CloneTask::task\{5} being destroyed

    \[#2] \[2007-02-19 12:39:15.812 'App' 288 error] \[imageProcessingTaskStep,425] VmiImportTask::task\{4} step "clone to VM" failed

    \[#2] \[2007-02-19 12:39:15.812 'App' 288 verbose] \[imageProcessingTaskWrapper,1117] Reporting image processing task failure for task CloneTask::task\{5}

    \[#2] \[2007-02-19 12:39:15.812 'App' 288 error] \[imageProcessingTaskWrapper,1124] ImageProcessingTask FAILED. Fault name: sysimage.fault.NfcConnectionFault

    \[#2] \[2007-02-19 12:39:15.875 'App' 288 info] \[imageProcessingTaskStep,196] VmiImportTask::task\{4} step "clone to VM" destroyed

    \[#2] \[2007-02-19 12:39:15.875 'App' 288 error] \[vmiImportTask,328] Cloning failed: sysimage.fault.NfcConnectionFault

    \[#2] \[2007-02-19 12:39:15.890 'App' 288 info] \[vmiImportTask,494] Removing destination VM

    \[#2] \[2007-02-19 12:39:15.937 'App' 288 info] \[vmiImportTask,502] Successfully connected to UfaManagedVMCreator

    \[#2] \[2007-02-19 12:39:16.437 'ManagedVMCreatorImpl::DestroyVM' 1924 info] Connecting to host 142.0.0.94 on port 902

    \[#2]

    \[#2] \[2007-02-19 12:39:18.515 'ManagedVMCreatorImpl::DestroyVM' 1924 verbose] Connected to stream: \[class Vmacore::Ssl::SSLStreamImpl:02CEF6A0]

    \[2007-02-19 12:39:18.515 'BaseLibs' 1628 warning] \[Vmdb_Unset] Unsetting unknown path: /vmomi/

    \[#2] \[2007-02-19 12:39:19.812 'ManagedVMCreatorImpl::DestroyVM' 1924 info] Authenticating user root

    \[#2] \[2007-02-19 12:39:20.437 'ManagedVMCreatorImpl::DestroyVM' 1924 info] Logged in!

    \[#2] \[2007-02-19 12:39:20.812 'App' 1924 info] \[managedVMCreator,1866] Waiting for VM destruction to complete...

    \[#2] \[2007-02-19 12:39:20.828 'App' 1924 verbose] \[rpcConnectionWrapper,785] Waiting for a task to complete...

    \[#2] \[2007-02-19 12:39:33.703 'ManagedVMCreatorImpl::DestroyVM' 1924 verbose] Shutting down VMDB service...

    \[#2] \[2007-02-19 12:39:33.734 'ManagedVMCreatorImpl::DestroyVM' 1924 verbose] Unregistering callback...

    \[#2] \[2007-02-19 12:39:33.781 'ManagedVMCreatorImpl::DestroyVM' 1924 verbose] ...done

    \[#2] \[2007-02-19 12:39:34.890 'App' 288 info] \[imageProcessingTaskStep,196] VmiImportTask::task\{4} step "create and clone to VM" destroyed

    \[#2] \[2007-02-19 12:39:34.921 'App' 288 info] \[imageProcessingTaskStep,196] VmiImportTask::task\{4} step "Clone VM" destroyed

    \[#2] \[2007-02-19 12:39:35.265 'App' 288 error] \[imageProcessingTaskImpl,552] VmiImportTask::task\{4}: Image processing task has failed with MethodFault::Exception: sysimage.fault.CloneFault

    \[#2] \[2007-02-19 12:39:35.265 'App' 288 verbose] \[imageProcessingTaskImpl,154] VmiImportTask::task\{4}: SetState to error

    \[#2] \[2007-02-19 12:39:35.953 'App' 400 verbose] \[disposable,121] object explicitly disposed: VmiImportTask::task\{4}

    \[#2] \[2007-02-19 12:39:36.125 'managedImportDestination' 400 verbose] Shutting down VMDB service...

    \[#2] \[2007-02-19 12:39:36.125 'managedImportDestination' 400 verbose] Unregistering callback...

    \[#2] \[2007-02-19 12:39:36.125 'managedImportDestination' 400 verbose] ...done

    \[#2] \[2007-02-19 12:39:36.359 'App' 764 verbose] \[disposable,121] object explicitly disposed: computer=\{31eec3da489e4e10733c1e8497aaeec557feb1a5}

    \[#2] \[2007-02-19 12:39:36.359 'App' 764 verbose] \[diskSet,119] Cleaning up computer's child objects

    \[#2] \[2007-02-19 12:39:36.359 'App' 764 verbose] \[diskSet,145] Unregistring disk id=disk=\{36e72f711ff88d228f967a0e90d0d28d380b962a}

    \[#2] \[2007-02-19 12:39:36.718 'App' 400 verbose] \[imageProcessingTaskImpl,123] VmiImportTask::task\{4} being destroyed



  • 2.  RE: Unknown error returned by wmware converter agent

    Posted Feb 19, 2007 04:06 PM

    It looks like it was waiting for something for 10 minutes and then timed out. Were you running Converter on the physical machine that you were converting? What were you trying to convert to? (destination). What kind of network is between the two servers? What OS are you trying to convert? Do you have Netbios running on the Source computer?

    \[#2] \[2007-02-19 12:28:00.296 'App' 288 verbose] \[imageProcessingTaskWrapper,668] (Re)Start waiting for property updates from CloneTask::task\{5}

    \[??] \[2007-02-19 12:38:06.328 'App' 1648 info] \[stub,42] NfcNetTcpWrite: timed out waiting for socket to be ready (101)



  • 3.  RE: Unknown error returned by wmware converter agent

    Posted Feb 22, 2007 12:34 PM

    It looks like it was waiting for something for 10 minutes and then timed out.

    OK but for what he is waiting for?

    Were you running Converter on the physical machine that you were converting?

    Converter is running in a VM on the new ESX-Server (VI3). The SourceVM-Folder is from a GSX-Server (3.2x) that i copied to a storage where i can grep it with the Convertertool.

    What were you trying to convert to? (destination).

    It was a w2k3-server VM with 12 GB diskspace.

    What kind of network is between the two servers?

    Gigabit-Network. The server are connected over the same switch.

    What OS are you trying to convert?

    w2k3 sp1

    Do you have Netbios running on the Source computer?

    I don´t understand what you mean.