vCenter

 View Only
  • 1.  Unable to upgrade VMTools

    Posted Aug 30, 2007 08:31 PM

    I'm near the end of my ESX 3.0.1 migration. I had a few VMs that encountered errors when I tried to upgrade VMTools (They were unable to uninstall the older version). Mounting the older version iso when prompted didn't work.

    FYI - After a lot of testing (love the snapshot feature), here's what worked for me

    Log on as local admin

    Click on the VMTools icon in the System Tray to find out what Build version you are running (under the About tab). Make a note of it. If the icon isn't there, you can run VMwareTray.exe from C:\Program Files\VMware\VMware Tools\

    Stop VMware Tools Service

    In Task Manager, end the two processes, VMwareUser.exe and VMwareTray.exe

    Delete C:\ProgramFiles\VMware and all its contents

    In Regedit, delete HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.

    Mount the iso that contains the version that is currently installed or run the msi.

    Choose Repair.

    Reboot

    Log back on as local admin

    Install the new VMTools normally. Reboot again.