ESXi

 View Only
Expand all | Collapse all

unable to backup using backupexec- VSS sync operation failed

  • 1.  unable to backup using backupexec- VSS sync operation failed

    Posted Aug 14, 2014 03:57 PM

    Hi,

    I had to upgrade my ESXI to 5.5 few days ago in order to resolve an issue. Upgrade process went smooth but now I cannot backup any of my machines.

    I get the error below

    Warning message from v1.pavillionagency.local:

    The guest OS has reported an error during

    quiescing. The error code was: 5 The error

    message was: 'VssSyncStart' operation failed:

    IDispatch error #8455 (0x80042307)

    warning

    T

    I use symantec backup exec 2014 and backup always stopped during the snapshot process.

    I did upgrade the VMware tools on the workstations, Looked and made sure that Symantec and Microsoft VSS writes do not collide.

    Backup exec error:

    Final error: 0xe00095a7 - The operation failed because the vCenter or ESX server reported that the virtual machine's configuration is invalid.

    Final error category: Resource Errors

    This is the second backup exec server I try to backup with. I just upgraded the hardware and symantec backup exec version as well.

    Please advise.


    D



  • 2.  RE: unable to backup using backupexec- VSS sync operation failed

    Posted Aug 14, 2014 04:58 PM

    I'm assuming you've already seen this?

    http://www.symantec.com/business/support/index?page=content&id=TECH139019

    It's old but might still be relevant. Looks like a few other folks are having the issue with 5.5 and BE 2012



  • 3.  RE: unable to backup using backupexec- VSS sync operation failed

    Posted Aug 14, 2014 05:04 PM

    Yes,

    I did encounter that KB with no luck.

    Thanks,


    D



  • 4.  RE: unable to backup using backupexec- VSS sync operation failed

    Posted Aug 14, 2014 05:32 PM

    What version of Windows is in the Guest OS.  Is it Windows Server 2012 R2.  He had a bunch of problems snapshotting / cloning Windows Server 2012 R2 due to the quiencing error, but once we put the Windows Backup Feature in as per the Vmware KB article: VMware KB: Quiesced snapshots fail on a Windows Server 2012 virtual machine with Microsoft Exchange 2013

    the problem went away.  not sure if this is your exact issue but figure I would mention it



  • 5.  RE: unable to backup using backupexec- VSS sync operation failed

    Posted Aug 14, 2014 06:45 PM

    I have 2 VMs of windows server 2008 R2 Standard with the latest updates

    D



  • 6.  RE: unable to backup using backupexec- VSS sync operation failed

    Posted Aug 14, 2014 07:04 PM

    A little more info -

    In the past there was a compatibility issue with VMware VSS Provider and BE VSS Provider. If you had both installed you'd get behavior like this and have to remove the VMware VSS provider. Just a shot in the dark. I don't use BE anymore for our VM's as it got to be too much of a pain, so I don't know if it's still applicable in BE 2014.

    EDIT - Looks like it's still applicable to 5.5 - VMware KB: Cannot create a quiesced snapshot of a virtual machine if Symantec BackupExec is installed within the vir…



  • 7.  RE: unable to backup using backupexec- VSS sync operation failed

    Posted Aug 14, 2014 07:25 PM

    Well, this is the thing.

    I believe the problem is snapshot related rather than VM VSS settings because I am able to backup information in the server using the agent. I am unable to backup the whole VMDK.

    Also, I have one VM without BE agent that I used to backup using the server's VMware agent only.

    I hope that make sense

    D



  • 8.  RE: unable to backup using backupexec- VSS sync operation failed

    Posted Aug 14, 2014 07:36 PM

    When you try and backup a VM do you have GRT enabled?


    Enabling GRT in BE 2014 allows you to backup the VM but pick out files you want to restore out of the VM if you want.  Try disabling this feature and backing up the VM as a test.  We found when GRT was enabled we had a lot of issues backing up the VM's.  We ended up turning it off in most installs and doing 2 backups.  1 for the VM's lock stock and barrel, and 1 file level on the critical systems to keep RTO/RPO in check.



  • 9.  RE: unable to backup using backupexec- VSS sync operation failed

    Posted Aug 14, 2014 06:51 PM

    Are the VSS components in VMware Tools installed on the VM's?



  • 10.  RE: unable to backup using backupexec- VSS sync operation failed

    Posted Aug 14, 2014 08:01 PM

    From AV exclude

    • All folders containing VHD, VHDX, AVHD, AVHDX, VSV and ISO files
    • Default virtual machine configuration directory, if used  C:\ProgramData\Microsoft\Windows\Hyper-V
    • Default snapshot files directory, if used  %systemdrive%\ProgramData\Microsoft\Windows\Hyper-V\Snapshots
    • Custom virtual machine configuration directories, if applicable
    • Virtual machine virtual hard disk files directory. By default, it is C:\Users\Public\Documents\Hyper-V\Virtual Hard Disks.
    • Custom virtual hard disk drive directories
    • Snapshot files directory. By default, it is %systemdrive%\ProgramData\Microsoft\Windows\Hyper-V\Snapshots.
    • Vmms.exe (Note: May need to be configured as process exclusions within the antivirus software)
    • Vmwp.exe (Note: May need to be configured as process exclusions within the antivirus software)
    • Additionally, when you use Cluster Shared Volumes, exclude the CSV path C:\ClusterStorage and all its subdirectories.

    copied from Hyper-V: Anti-Virus Exclusions for Hyper-V Hosts 

    also include the Backup Exec processes in the antivirus exclusions



  • 11.  RE: unable to backup using backupexec- VSS sync operation failed

    Posted Aug 14, 2014 08:28 PM

    JPM - I disabled GRT and it still died while processing snapshot

    Lenora - I do not use Hyper-V I have VMware. and the backup server does not have any AV installed.

    .



  • 12.  RE: unable to backup using backupexec- VSS sync operation failed

    Posted Aug 14, 2014 09:21 PM

    have you seen this link and gone through the troubleshooting steps listed? http://www.symantec.com/docs/TECH129724

    check to see if there are multiple providers installed by running vssadminlist providers at the command prompt.

    If this doesn't help, enable debugging on the virtual machines through the Backup Exec 2014 Debug Monitor.   http://www.symantec.com/docs/TECH63926