Skyline

 View Only
  • 1.  Unable to add vCenter Server in Skyline Collector

    Posted Jun 05, 2019 04:28 PM

    When trying to add vCenter Server in the Skyline Collector getting error message:

    Couldn't create collection task to test endpoint. -> java.lang.RuntimeException: Couldn't login the client. -> Couldn't login the client. -> General failure. -> https://skyline-field.rac.raccorp.corp:7444/sso-adminserver/sdk invocation failed with "org.apache.http.conn.HttpHostConnectException: Connect to skyline-field.rac.raccorp.corp:7444 [skyline-field.rac.raccorp.corp/127.0.0.1] failed: Connection refused (Connection refused)" -> Connect to skyline-field.rac.raccorp.corp:7444 [skyline-field.rac.raccorp.corp/127.0.0.1] failed: Connection refused (Connection refused) -> Connection refused (Connection refused)

    Need help. Thank you.



  • 2.  RE: Unable to add vCenter Server in Skyline Collector

    Posted Jun 05, 2019 06:17 PM

    Are you using a SSO domain different than vsphere.local ? If yes you need to select the option to use Custom SSO Configuration, see: Add a vCenter Server



  • 3.  RE: Unable to add vCenter Server in Skyline Collector
    Best Answer

    Broadcom Employee
    Posted Jun 05, 2019 06:30 PM

    Hello Alfredo77,

    Welcome to communities,

    As per the error message, this issue could have occurred for multiple reasons. Please find the action plan mentioned below:

    1. Make sure you are able to login to vCenter server using the user which you are using for vCenter registration on skyline.
    2. If the vCenter is configurred with external PSC, enable "Use Custom SSO Configuration"
    3. Check if you are able to connect to vCenter from skyline using the below command:
      #curl -v telnet//<ip address/fqdn> <7444>
    4. Make sure the vCenter and Skyline are having the same time / timezone

    For your refrence: Unable to add the second vCenter to collector



  • 4.  RE: Unable to add vCenter Server in Skyline Collector

    Posted Jun 05, 2019 06:32 PM

    Please disregard, issue solved. Typing wrong FQDN.