View Only
  • 1.  Unable to add ANY NFS datastores

    Posted Jun 01, 2011 06:34 PM

    So I've somewhat already resolved this, but I wanted to make sure that I didn't more harm than good. So first a little history...

    On one of my hosts I had removed a number of NFS datastores that we had setup for testing. During deletion I had experienced a strange issue where I one of the NFS datastores I deleted reappeared after refreshing and then I attempeted to delete it again and received an error (don't have it, sorry). A few days later, I attempted to add a NFS datastore and kept receiving the error message..

    Call "HostDatastoreSystem.CreateNasDatastore" for object "datastoreSystem-9" on vCenter Server "" failed.
    Operation failed, diagnostics report: Unable to get Console path for Mount

    After talking to VMWare TS, they insisted that it must be a permisisons issue and that I should contact my SAN provider (Nexenta). However, I'm positive that this ESXi host has access to this NFS export (and has no root squash on). I'm able to attach this NFS export to another ESXi host that has the same access permissions (allowing private VLAN IP space

    Just for grins I tried attaching a NFS share (that is fully open) from a OSX server to the problem host, and I recieved same error as above. However I can attach this ALL my other ESXi hosts successfully.

    I had this feeling that something was corrupted on my ESXi installation, and I just happened to be running resxtop on the problem ESXi host and under "disk devices" I could see the NFS share name that I orginally had issues deleting and currently wasn't visible in the current datastore list!

    So...After a bit of research, I opened up the esx.conf file and I could totally see the original NFS share name that had issues deleting. I removed that from the esx.conf, saved it and then rebooted. It fixed it. I can now add all the other datastores I couldn't previously. BUT, if I try to add the same problem NFS share with the exact hostname and path as the one I removed from the esx.conf file, I get the same error again (even with a new "Identification name").. Sounds like there is still something left in the configuration? Should i be worried? Was editing the esx.conf file in that manner going to cause me more issues down the road?

    Thanks all!

  • 2.  RE: Unable to add ANY NFS datastores

    Posted Jun 26, 2012 02:57 PM

    Hi Folks,

               I had the very same issue as the above. What happened was that I had an NFS DataStore(DS) that was re-named at exactly the same time that I was configuring an NFS DS with the same name.As described above this threw up an error which I didn't pay much attention to. Even when the DS was re-named to what it should have been, I still could not create a DS with that name.

              None of the hosts in that cluster could create the same datastore on the same NFS export with the same name. What I was able to do to workaround is:

    1. Make sure none of the NFS datastores have a duplicate name. Delete any "Ghost entries".

    2. Verify all your permissions are correct - as stated above this was not the issue in my case either.

    3. Create an NFS DataStore with a temporary name. With the correct IP/Folder information.

    4. Browse the DS and make sure permissions are expected e.g. RW = Directory create and Directory Delete from all your hosts.

    5. Re-name the DS to the name that you had originally planned.

    6. Verify this is visible from all other hosts in the cluster.


  • 3.  RE: Unable to add ANY NFS datastores

    Posted Mar 17, 2017 08:08 AM

    I had very similar issue and this URL help me:

    Atlantis Portal - Knowledge Base

  • 4.  RE: Unable to add ANY NFS datastores

    Posted Dec 08, 2017 06:53 PM

    Spot on!

    Atlantis Portal - Knowledge Base

    Fixed my problems in less than 5 min

  • 5.  RE: Unable to add ANY NFS datastores

    Posted Mar 22, 2017 01:56 PM

    Hi fellows I think this issue is related to this Attempting to mount the NFS volume fails with the error: Unable to resolve hostname (2036182) | VMware KB

    in the other hand I work for a storage company and got the same error. What resolved the issue was on the storage side the LIF was migrated to another node and then user was able to mount  the data store using NFS. Once I get more details I will share with you

  • 6.  RE: Unable to add ANY NFS datastores

    Posted Dec 08, 2017 06:54 PM

    Seen this in the past and the link did help.