View Only
  • 1.  Trying to test ESX4 with test iSCSI (FreeNAS)

    Posted Jul 01, 2009 08:57 PM


    I'm learning about VSphere ESX4 and iSCSI and a simple way to evaluate it is to use FreeNAS along with the ESX4 60 day trial. We will be getting a full blown EMC SAN and VSphere solution installed within a few months, but I'd like to have a little bit of playtime first hand.

    So I have FreeNAS installed in VMWare Workstation along with 4 SCSI 72gb disks. These disks are in RAID5 and iSCSI is enabled. I can connect to the iSCSI using the Microsoft iSCSI initiator. I can format the disk and store files on it. It even worked with ESXi 3.5, but I since then wiped it to try the latest version of VMWare VSphere4.

    For the life of me, I cannot add this iscsi datastore. In vSphere client under Configuration > Storage Adapters, I have the vmhba33 iSCSI connection to the FreeNAS box NetBSD iSCSI Disk (,L,0x4a71bbb1667c11de), runtime name: vmhba33:C1:T0:L0, 216GB capacity.

    Now under Configuration > Storage, I attempt to create the datastore. Add Storage > Disk/LUN > Choose my only iSCSI option shown, name it vmds1, 256GB, Block size: 1MB, Maximize capacity, next, finish. Within a few minutes I will always get an error "Error during the configuration of the host: Unable to create Filesystem, please see VMkernal log for more details". Under FreeNAS I tried formatting it as FAT32, EXT2, NTFS, or leaving it unformatted. None work.

    I remember having a heck of a lot of difficulty getting this to work with ESXi 3.5, but I did end up getting things going, along with 2 virtual machines up and running. Although I blew it all away to try vSphere 4. Now I don't remember what I did, or maybe this version doesn't want to play nice with FreeNAS iSCSI implementation.

    Under the Events tab I see a lot of "Lost connectivity to storage device,L,0x4a71bbb1667c11de. Path vmhba22:C1:T0:L0 is down. Affected datastores: "VMDS1". Recovery attempt is in progress and outcome will be reported shortly."

    There is one entry that says "Successfully restored access to volume 4a4bc1e1-f4bb4a45-cc91-000c2910ccd5 (VMDS1) following connectivity issues"

    Although this is followed by much more of the above "Lost connectivity" messages.

    I'm at wits end. I really want to play with this using iSCSI to simulate our future iSCSI SAN from EMC. Any help is greatly appreciated!

  • 2.  RE: Trying to test ESX4 with test iSCSI (FreeNAS)
    Best Answer

    Posted Jul 01, 2009 09:03 PM

    I use several for lab purposes but for me Openfiler has been easy to setup and administer. A decent free ISCSI SAN.

    Also, since you are looking at EMC you might want to take a look at their Celerra VSA (virtual SAN) for lab use.

    Check out this post from Chad -

  • 3.  RE: Trying to test ESX4 with test iSCSI (FreeNAS)

    Posted Jul 02, 2009 03:40 PM

    Ok, I've installed Openfiler and what do you know, the iSCSI connection now works great! Wonder if FreeNAS isn't fully complying with the iSCSI specification? Oddly I had it working with ESXi 3.5, but of course it wasn't so easy.

    Thanks for the link for the Celerra simulator. Might want to give that a shot. Seems pretty complex to get setup, but we'll see what time allows.

  • 4.  RE: Trying to test ESX4 with test iSCSI (FreeNAS)

    Posted Jul 03, 2009 02:34 AM

    That's great to hear!!

    If you found the information I provided helpful, please consider awarding points.



  • 5.  RE: Trying to test ESX4 with test iSCSI (FreeNAS)

    Posted Jul 14, 2009 12:21 AM

    Do a chmod 777 on the iscsi file you created in FreeNAS. If you also share out the iSCSI file thru CIFS, you can give Everyone Full Control from a Windows box. I had the same error and that fixed it...

  • 6.  RE: Trying to test ESX4 with test iSCSI (FreeNAS)

    Posted Nov 27, 2009 03:19 PM


    Has anybody gotten esx4 to work with EMC celerra simulator product? I'm in the process of trying it now. The lun is all created and I can see it under the Storage Adapters in the VI client. However, I cannot see it when I attempt to add to the list of datastores. I'm selecting Storage/Add Storage/Disk-LUN and then Next. I'm not seeing the LUN.

    Any help would be greatly appreciated!

  • 7.  RE: Trying to test ESX4 with test iSCSI (FreeNAS)

    Posted Mar 03, 2010 02:09 PM

    FreeNAS is a good option and easy to setup too. I like it. Here are the easy steps to connect FreeNAS with vSpeher 4.