ESXi

 View Only
  • 1.  Timeout after inactivity on ESX console?

    Posted Sep 21, 2010 04:35 PM

    Trying to enforce a timeout after inactivity on the ESX console. "Followed the KB Configuring an ESX console session timeout after inactivity"

    Step 1 is to located file /etc/.bashrc file. I did not see this file in the /etc directory. There is a bashrc.

    You are to add these lines to that file:

    echo "TMOUT=300 >> /etc/bashrc

    echo "readonly TMOUT" >> /etc/bashrc

    echo "export TMOUT" >> /etc/bashrc

    I added these lines and then logged out and back in (uername: root).

    I do not get timed out. Is there something wrong with what I'm doing or does this not work for root?

    Appreciating any responses.



  • 2.  RE: Timeout after inactivity on ESX console?

    Posted Sep 21, 2010 05:21 PM

    echo "TMOUT=300 >> /etc/bashrc

    echo "readonly TMOUT" >> /etc/bashrc

    echo "export TMOUT" >> /etc/bashrc

    I'm not sure whether this is /etc/.bashrc or /etc/bashrc. No matter which one it is, in the first line the closing quotes are missing (behind the 300). Take a look into the file you edited and make sure it contains the TMOUT=300 setting.

    André



  • 3.  RE: Timeout after inactivity on ESX console?

    Posted Sep 21, 2010 07:03 PM

    Believe it or not, that first line had the one quote. I thought that might be a problem.



  • 4.  RE: Timeout after inactivity on ESX console?

    Posted Sep 21, 2010 07:13 PM

    It looks like the missing double quote on the end.

    Also /etc/bashrc is correct .bashrc is what you would see in a personal folder.

    www.phdvirtual.com, makers of PHD Virtual Backup for Vmware and Xen Server, formally esXpress