vCenter

 View Only
  • 1.  Support for open source vmware tools

    Posted Jul 30, 2018 11:41 PM

    Hi,

    I'm running debian (jessie/sid, 3.13.0-145-generic) that has the open source flavor of vmware tools installed.  Here are the version outputs:

    # vmware-toolbox-cmd  -v

    9.4.0.25793 (build-1280544)

    # vmware-checkvm -h

    VM's hw version is 4

    VMware software version 6 (good)

    In the vSphere GUI, I see this for VMware tools:

    Running, version:2147483647 (Guest Managed)

    A VMware Tools implementation is installed on the guest operating system, but it is not managed by VMware. The VMware Tools status is unknown.

    This version of vmware tools was installed by the server vendor, who also controls the entire OS.

    Assuming that I have a support contract, am I able to open and work a support ticket with VMware regarding this server?  IOW, am I supported running the open source version of tools, or must I install a different version?

    This page makes me think that I am supported:

    Using Open Virtual Machine Tools

    But i want to check my understanding.

    Thanks!

    David



  • 2.  RE: Support for open source vmware tools

    Posted Jul 31, 2018 12:15 AM

    Below Debian releases are supported with the Open VM Tools. Check with respect to the ESXi version the hosts are running on -

    VMware Compatibility Guide - Guest/Host Search

    Please consider marking this answer as "correct" or "helpful" if you think your questions have been answered.

    Cheers,

    Supreet



  • 3.  RE: Support for open source vmware tools

    Posted Jul 31, 2018 12:41 AM

    Hi SupreetK,

    Just to doublecheck, when you say "supported with the Open VM Tools", does that mean that VMware won't reject my attempt to open a ticket solely because I'm running the open source version of vmware tools?

    Thanks,

    david



  • 4.  RE: Support for open source vmware tools
    Best Answer

    Posted Jul 31, 2018 01:11 AM

    Absolutely! It's just that the underlying guest operating system should be supported (as per VMware HCL) with the ESXi version.

    Please consider marking this answer as "correct" or "helpful" if you think your questions have been answered.

    Cheers,

    Supreet



  • 5.  RE: Support for open source vmware tools

    Posted Jul 31, 2018 12:47 AM

    Have a read as well of this KB https://kb.vmware.com/kb/2073803