ESXi

 View Only
  • 1.  Snapshot deletion issues - task already in progress

    Posted Sep 30, 2014 03:09 PM

    Hi,

    We have started to see this issue more regularly now and so I thought it was time to ask the question. I wil raise a support call if required.

    We use Veeam Backups in our environment (esxi 5.5) and so every VM (over 3000)  will essentially get a Veeam snapshot applied at some point during a 24 hour period. We are seeing that occasionally Vcenter reports an error stating that it cannot delete the snapshot due to a task already in progress, even though the veeam snapshot appears to have been successful.

    In the worst case the VM in question is unresponsive, cannot be modified via vcenter, and so the only solution that we have found so far is to SSH onto the relevant ESXi host and force kill the World ID correspondoing to the VM.

    My question really at the moment is - what may be the cause of this. I'm sure the Veeam folks will say that they are just calling the correct vsphere API to delete a snapshot and so vsphere / vcenter is sometimes getting 'confused' about the state of the snapshots causing VMs to go unresponsive. Is there an inherent issue with snapshot deletion that can happen rarely, but we see it quite oiften due to the number of snapshots being added and deleted in our environment ?

    thanks in advance



  • 2.  RE: Snapshot deletion issues - task already in progress

    Posted Oct 03, 2014 09:38 AM

    I have heard that Veeam messes up when there are a lot of backups are scheduled in a single job.

    If you are using snapshot manager to check for snapshots that is not the correct way to do it. Look at where each disk is mounted and the file name ending. Snapshots have several digits at the end.

    Just curious, have the backups been verified to actually work?



  • 3.  RE: Snapshot deletion issues - task already in progress

    Posted Oct 03, 2014 03:33 PM


    thanks for the reply, although I'm not sure why having lots of backups in a single job will mess up but thats a question for the veeam folks I guess.

    The backups work fine (and even the restores - which is nice ;-)).

    I am actually seeing two different problems -

    1.  When Veeam tries to remove the snapshot and Vsphere keeps reporting that another task is in progress (sometimes happens on snapshot creation too)

    2. VMs are left in  a state where 'VM disk consolidation is needed'.  snapshot manager reports no snaps but the underlying disks are running offdeltas. (this is happenning daily for up to 5 different VMs out of 3000 - so not a massive problem, but annoying)

    There are a number of threads that have reported similar issues but I am really trying to understand what the scenario / symptoms are that may be causing it in the first place.

    regards