vCenter

 View Only
  • 1.  Slow Guest OS After Successful Conversion

    Posted Jun 06, 2007 03:52 PM

    Hello,

    I successfully converted a Server 2003 machine to virtual. But my problem now is that it's unbearably slow. I've allocated the Guest OS twice the amount of resources that it had when it was on a physical box, but it's still on snail status.

    Ideas, comments, suggestions?



  • 2.  RE: Slow Guest OS After Successful Conversion

    Posted Jun 06, 2007 04:16 PM

    Verify that the VM has a single vCPU and that the HAL is set to ACPI instead of ACPI Multiprocessor. You can check that in the Device Manager for Computer.



  • 3.  RE: Slow Guest OS After Successful Conversion

    Posted Jun 06, 2007 05:08 PM

    Here's some tips...

    What should I do after I successfully convert my virtual machine?

    If you change from a multi-processor system to a uni-processor system you need to manually change the HAL on the Windows server after the conversion. To do this go into Device Manager after the machine first boots and discovers it's new hardware and then click on Computer then right-click on the processor and select Update Driver. Then select Install from specific location and then Don't search I will choose the driver to install. Then select show All compatible hardware and select the appropriate processor. For example, if you went from a dual cpu to a single cpu then select ACPI uni-processor PC instead of ACPI multi-processor PC. You will need to reboot once you change this. To verify what HAL you are using you right-click your hal.dll in c:\windows\system32 and select the Version tab and select Internal Name and it should say halmacpi.dll for multi-processor acpi and halacpi.dll for uni-processor acpi.

    Next clean up all the non-present hardware after the P2V conversion. To do this go to a CMD prompt and type SET DEVMGR_SHOW_NONPRESENT_DEVICES=1 and then DEVMGMT.MSC and then select Show Hidden Devices. Delete any old grayed out physical hardware.

    Next remove any vendor specific applications/drivers. For example on a HP server you should go to Add/Remove programs and remove any HP management agents, survey utility, array config utility, version control agent, etc. Also check your NIC and make sure there are no vendor specific drivers there (ie. teaming). Check the Services to see if all there is anything vendor specific related there and disable any services that are.



  • 4.  RE: Slow Guest OS After Successful Conversion

    Posted Jun 06, 2007 06:28 PM

    Thanks guys. I've tried everything you suggested, but it's still hasn't improved performance.



  • 5.  RE: Slow Guest OS After Successful Conversion

    Posted Jun 06, 2007 06:35 PM

    By "slow" can you elaborate? Is it taking a long time to come back with a result?

    Think of all the things that could have changed-- did the VM go on a different network so that something has to time out before proceeding?

    Are there any services that have failed?



  • 6.  RE: Slow Guest OS After Successful Conversion

    Posted Jun 06, 2007 06:54 PM

    By slow I mean everything takes a long time to respond. The mouse, opening applications, opening windows. The VM is on the same network. Services look good.

    The virtual hard drive is constantly active. The problem has to lie around it.



  • 7.  RE: Slow Guest OS After Successful Conversion

    Posted Jun 06, 2007 07:16 PM

    Is this the case with both the VM Console and using Remote Desktop?

    For the presentation portion, make sure that the Hardware Acceleration is set to full.



  • 8.  RE: Slow Guest OS After Successful Conversion

    Posted Jun 06, 2007 09:52 PM

    Using VNC, it's impossibly slow. Using VM Console, it slow.

    Hardware acceleration is set to full.



  • 9.  RE: Slow Guest OS After Successful Conversion

    Posted Jun 13, 2007 05:38 PM

    I experinced this after cloning around 10 machines, abour 50% started . . hitching . . for lack of a better term. Took around 15 minutes to boot windows as a result. My fix ended up being time.

    I waited, the next day they all worked great.