ESXi

 View Only
Expand all | Collapse all

Reinstall EXSi and re-add host to cluster

  • 1.  Reinstall EXSi and re-add host to cluster

    Posted Apr 01, 2020 08:02 AM

    Hello everybody.

    I had some problems with one host.

    I removed it from distributed switch, then from vCenter, reinstall fresh ESXi and trying to add host to the cluster.

    Error occurred while applying profile:

    And now all portgroups does not work at new host. After migrating VM to the host with troubles network card is turned off. If I turn it on manually, link is going up,but VM have not connection...

    Please help me figure out the situation...



  • 2.  RE: Reinstall EXSi and re-add host to cluster

    Posted Apr 01, 2020 08:12 AM

    Have you connected esxi host back to dvswitch and assign proper vmnics to uplink? Also, the portgroups as you said are standard portgroup or dvswitch port group? If possible share the screenshot of vswitch or dvswitch connectivity.



  • 3.  RE: Reinstall EXSi and re-add host to cluster

    Posted Apr 01, 2020 09:02 AM

    Nawals​, sure I did it...And portgroup is dvs-portgroup.

    Topology is here



  • 4.  RE: Reinstall EXSi and re-add host to cluster

    Posted Apr 01, 2020 11:44 AM

    Okay. Now your fresh esxi install version and build number match with other hosts? Can you please check the firewall rules which is showing not found enabled or disable. also, check are really using those rules which showing not found.



  • 5.  RE: Reinstall EXSi and re-add host to cluster

    Posted Apr 01, 2020 02:00 PM

    @Nawals, build of ESXi the same, like another hosts. In my humble oppinion, this firewall rules (their absence) blocks some control-plane traffic for DVSwitch and VMs cannot to use network after migrarion. So, first, I need to apply profile and rules. Then need to check VMs connectivity through DVSwitch. I cannot to understand why firewall rules does not applying...



  • 6.  RE: Reinstall EXSi and re-add host to cluster

    Posted Apr 01, 2020 08:35 AM

    After you add the newly installed host to the inventory the first step is to make sure the host is compliant with the host profile. Then add it to the cluster and to the Distributed Switch. When you keep the host in maintenance mode you can fix any errors before you migrate workloads to that host.



  • 7.  RE: Reinstall EXSi and re-add host to cluster

    Posted Apr 01, 2020 08:53 AM

    jburen​, sure I did your scenario. I have troubles with applying host profile. And I dont know how I can to fix it.



  • 8.  RE: Reinstall EXSi and re-add host to cluster

    Posted Apr 01, 2020 08:57 AM

    So what happens when you try to remediate the host?



  • 9.  RE: Reinstall EXSi and re-add host to cluster

    Posted Apr 01, 2020 09:14 AM

    jburen​ what means "remediate" ?



  • 10.  RE: Reinstall EXSi and re-add host to cluster

    Broadcom Employee
    Posted Apr 01, 2020 01:16 PM

    Remediate = make the host compliant with the host profile



  • 11.  RE: Reinstall EXSi and re-add host to cluster

    Posted Apr 01, 2020 01:49 PM

    scott28tt​, I wrote it in my first message. When i trying to apply the profile I see messages like my first message...



  • 12.  RE: Reinstall EXSi and re-add host to cluster

    Broadcom Employee
    Posted Apr 01, 2020 01:50 PM

    You asked what "remediate" means in a reply above.



  • 13.  RE: Reinstall EXSi and re-add host to cluster

    Posted Apr 01, 2020 02:03 PM

    I didn't understand why you asked "So what happens when you try to remediate the host?" if I wrote it in my first message. May be this is my language troubles, sorry.



  • 14.  RE: Reinstall EXSi and re-add host to cluster

    Posted Apr 01, 2020 02:07 PM

    Because applying a profile is not the same as remediating a host... When you apply a profile you see errors as the host is not compliant. When you remediate a host you try to make the host compliant to the profile by changing host configuration settings.



  • 15.  RE: Reinstall EXSi and re-add host to cluster

    Posted Apr 01, 2020 02:30 PM

    jburen​, I tried to remediate profile again:

    But after that I see this errors again:



  • 16.  RE: Reinstall EXSi and re-add host to cluster
    Best Answer

    Posted Apr 01, 2020 02:32 PM

    Please check the VIBs... It could be you're missing one or more on your newly installed host.



  • 17.  RE: Reinstall EXSi and re-add host to cluster

    Posted Apr 01, 2020 04:16 PM

    jburen​, you right. I found difference in some vibs. One of them is

    esx-nsxv6.5.0-0.0.7563456

    I installed it and then, profile applied correctly. DVS is working fine now.

    Cause of this trouble, I think, incorrect removal of the NSX.

    In any way, you helped me a lot. Thank you very much...



  • 18.  RE: Reinstall EXSi and re-add host to cluster

    Posted Apr 01, 2020 02:04 PM

    Could it be that you are missing some VIBs on the newly installed host? Please compare two hosts with esxcli software vib list