ESXi

 View Only
  • 1.  rdp & auto restart

    Posted Jun 12, 2023 10:14 PM

    Hi,
    I installed ESXi on my server and my VM created is working on the network, everything ok.

    But I have two problems that I don't understand how to solve:
    - I am unable to access the VM via RDP from a LAN's pc (I always have to go through esxi)
    - if the power fails the VM shuts down and does not restart

    Do you have any suggestions?
    Thanks

    A.



  • 2.  RE: rdp & auto restart

    Posted Jun 13, 2023 06:42 AM

    is it home lab

    if yes you need to connect 2nd nic and provide same IP range as LAN PC have

    are you able to ping vm from LAN PC



  • 3.  RE: rdp & auto restart

    Posted Jun 13, 2023 06:44 AM

    1. You have to configure the Network and Firewall within your Windows GuestOS.  In the same way as with a phys. OSI.  Assumed that you have configured your VM with a vNetwork card and enable it.

    2. There is a Autostart/Stop VM option which let you specified which VMs starts automaticly in which order. You need to enable it.

    Regards,
    Joerg



  • 4.  RE: rdp & auto restart

    Posted Jun 19, 2023 08:03 PM

    Hi,

    I'm using ESXi 8, I set an automatic restart with a 60 second delay, but the VM doesn't start. I always have to restart it manually. What am I doing wrong?

     

    thank you



  • 5.  RE: rdp & auto restart

    Posted Jun 19, 2023 11:29 PM

    You have enble the feature and than configure the feature right?



  • 6.  RE: rdp & auto restart

    Posted Jun 20, 2023 06:47 AM

    Hi,
    I right clicked on the VM and choose enable.
    Then, configured the seconds. I don't see anything else.

    In fact, if I right click on the VM, I now see "disable".
    So, it's active.

    Does something that I have a free license have to do with it?
    I registered as a company and got the key which I then entered in esxi.

    Thank you



  • 7.  RE: rdp & auto restart

    Posted Jun 13, 2023 07:21 AM

    Hi,

    Chech if Vm is reacheble from your local PC and you have enabled the RDP on your windows machine.

    Please check below document to configure autostart of VM with the system:

    https://docs.vmware.com/en/VMware-vSphere/6.7/com.vmware.vsphere.vm_admin.doc/GUID-5FE08AC7-4486-438E-AF88-80D6C7928810.html

    Regards,

    Sachchidanand