ESXi

 View Only
  • 1.  Problems with Server 2012R2 customization

    Posted Sep 04, 2015 05:02 PM

    (I'm very new to VMware, so bare with me :smileyhappy:)

    I'm attempting to set up a Server 2012R2 template and customization on our new ESXi 6 host.  This is my first attempt at setting up something like with VMware products (we are migrating from XenServer), and I just can't get this working.

    I set up the 2012R2 VM and configured only a few basic things:  installed the Tools, set up the VMXNet 3 driver, installed Classic Shell (just for the start menu), and set up NSClient++ for our monitoring.

    Based on what I read on the Internet, I then cloned the VM to a template.  I also set up Guest OS Customization rules.  Because we use a lot of OEM licenses, I did not fill out the license information (if that matters).  I also did not select "Use custom SysPrep answer file".

    When I deploy a new VM with my 2012R2 template and customization routine, it boots up, and nothing has changed.

    When I reboot the system, I get the "VMware Image Customization in progress" display on my screen, but it only stays up for 30ish seconds.  Then, it prompts me to change the Administrator password (which I don't think should be happening), and after that, it logs in to the machine.  However, the machine still has the template netbios name, has not been joined to the domain, and still has DHCP (the IP did not get set).

    I've read in other threads that you need to manually reboot the machine at this point.  After rebooting, I again get the "VMware Image Customization in progress" message, and then I get to the Ctrl+Alt+Del screen.  After logging in, everything is still the same.  I've tried additional reboots, both from within Windows and from the Guest OS menu, and shutdown/startups, and the customizations never take effect.  It does show the "VMware Image Customization in progress" after every reboot, but nothing's happening.

    I'm not super experienced with Windows server management (I'm the Linux guy in our shop), so any particular logs to look at?  I've looked at the Sysprep logs in C:\Windows\System32\Sysprep\Pather, and it looks like it's working (but, I'll be honest, I don't really know what I'm looking for).

    Is there something I'm doing wrong?  This is my first time with VMware (we used to be a XenServer) shop, and one of the selling points was the "super easy" customization for templates.  From everything I've read and done, that sure looks to be the case, but it's just not working!



  • 2.  RE: Problems with Server 2012R2 customization

    Posted Sep 07, 2015 10:58 PM

    Hi nick2253,

    Welcome to the community.

    To fix Customisation Boot Looping in ESXi follow this KB which is just stopping sysprep.

    http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1018378

    As for building a Template, I would recommend following Michael White's extremely detailed template guide -  How to build a Windows 2012 R2 VMware Template | Notes from MWhite

    If it is still going wrong there might be a bug to report, so keep us posted.

    Kind Regards

    @iiToby



  • 3.  RE: Problems with Server 2012R2 customization

    Posted Sep 08, 2015 02:45 PM

    iiToby‌:

    The problem is not the boot loop; that I've already fixed multiple times following that exact article in the process of testing/debugging.  The issue is that the customization doesn't take effect, and leads to a boot loop, every single time!

    As far as the template goes, my template is nearly identical to Michael White's, except with customization appropriate for my network, and without all the excessive software (who puts Chrome on a server?  Why are you browsing the internet from a server!?).

    My problem is not the template; it's the VMware customization routine.  That doesn't work.  Even on a completely fresh installation (plus VMware tools), it doesn't work. Based on some articles I've read here for 5.5, it sounds like this issue I have used to be a common problem, but it was all supposedly fixed.  But yet, here I am.  I was hoping someone might have some new information to help me fix this issue.

    Thanks,

    Nick



  • 4.  RE: Problems with Server 2012R2 customization

    Posted Sep 10, 2015 10:49 AM

    When it is prompting to reboot to complete the customization press Shift+F10 and try to check the log files in the following location. You will get to know the exact error.

    C:\Windows\Panther

    C:\Windows\Panther\UnattendGC <- which shows actual customization stuff  oobeSystem phase

    C:\Windows\System32\sysprep\Panther

    c:\windows\temp\vmware-imc\ 



  • 5.  RE: Problems with Server 2012R2 customization

    Posted Oct 20, 2015 06:02 PM

    Nick2253,

    I feel your pain. I have been struggling with the exact same issue. Did you ever figure out what the fix was?

    Thanks,

    Dustin



  • 6.  RE: Problems with Server 2012R2 customization

    Posted Oct 20, 2015 08:21 PM

    customization wizard - sysprep failing to join domain

    Not sure if it's related but having similar issue with w7 and windows 2008 r2 template deployments

    Tom



  • 7.  RE: Problems with Server 2012R2 customization

    Posted Oct 23, 2015 04:49 PM

    For those of you following this thread. We were able to fix our issue. So we disable Desktop Experience feature to reduce security vulnerabilities and did this on our template we are deploying these servers from. Apparently, sysprep uses this to customize the OS.

    We enabled Desktop Experience feature on the template and voila! It works now.

    Also, Matt Wrock has this great blog that explains this - http://www.hurryupandwait.io/blog/adventures-in-sysprep-and-the-failed-quest-for-disk-cleanup-on-server-2012-r2

    Hope this helps!

    Thanks,

    Dustin