View Only
  • 1.  PowerCLI Install Problems

    Posted Jun 21, 2019 02:14 PM

    Tried updating to the latest PowerCLI 11.3 and ran into problems.

    Any ideas???

    Ran this Uninstall Command first

    Get-Module -Name VMware* -ListAvailable | Uninstall-Module -Force -Confirm:$false

    Then ran this command to install and got this error.

    Install-Module -Name VMware.PowerCLI -Confirm:$false -AllowClobber -Force

    WARNING: Source Location ''

    is not valid.

    PackageManagement\Install-Package : Package 'VMware.VimAutomation.Core' failed to download.

    At C:\Program Files\WindowsPowerShell\Modules\PowerShellGet\2.1.5\PSModule.psm1:9534 char:34

    + ... talledPackages = PackageManagement\Install-Package @PSBoundParameters

    +                      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

        + CategoryInfo          : ResourceUnavailable: (C:\Users\tkutil....13964826.nupkg:String) [Install-Package], Excep


        + FullyQualifiedErrorId : PackageFailedInstallOrDownload,Microsoft.PowerShell.PackageManagement.Cmdlets.InstallPac


  • 2.  RE: PowerCLI Install Problems

    Posted Jun 21, 2019 02:25 PM

    Seems to be working for me (just tried).
    Does that error keep coming back when you retry?

    Do you have similar errors with other modules?

  • 3.  RE: PowerCLI Install Problems
    Best Answer

    Posted Jun 21, 2019 02:25 PM

    Got the install to work by dropping off the work network and connecting via wi-fi.