Automation

 View Only
  • 1.  powercli install / compatibility question

    Posted Sep 08, 2010 03:22 PM

    I have two questions:

    1) I want to load the powercli on a windows 7 system that currently runs the vsphere client and vmware workstation.

    Can I run the powercli on this system. I can't find the software compatibility matrix for this and its not in the guide.

    2) can I run the powercli on a w2k8r2 server?



  • 2.  RE: powercli install / compatibility question

    Posted Sep 08, 2010 03:29 PM

    Yes, you can (Win7 & W2K8 R2).

    Win7 is in the supported platform. See the Release Notes. W2K8 R2 is not, but I have it running without any apparent problems.

    There could be some 64-bit issues with some cmdlets which you can bypass by starting PowerCLI in 32-bit mode.

    ____________

    Blog: LucD notes

    Twitter: lucd22



  • 3.  RE: powercli install / compatibility question

    Posted Sep 08, 2010 03:31 PM

    I'm running windows 7 32 bit on the desktop which I will be doing the develoment

    The w2k8r2 is, of course, 64 bit. I was going to use it to run the production scripts.



  • 4.  RE: powercli install / compatibility question

    Posted Sep 08, 2010 03:34 PM

    Although W2K8 R2 is not in the supported platforms list it works for me.

    Win7 32-bit shouldn't be a problem.

    ____________

    Blog: LucD notes

    Twitter: lucd22



  • 5.  RE: powercli install / compatibility question
    Best Answer

    Posted Sep 08, 2010 03:34 PM

    Hi Marvin,

    the answer to both questions is yes you can. In fact I am running on my Windows 7 pc the configuration you describe.

    Regards, Robert



  • 6.  RE: powercli install / compatibility question

    Posted Sep 08, 2010 05:04 PM

    many thanks for the input. I had submitted an SR asking that question but VMware said they couldn't answer it since I was not a partner (SDK no professional support), and the manual didnt address the issue of running products together (they are usually pretty good at that).