ESXi

 View Only
  • 1.  Please HELP: cannot Increase datastore with new LUN

    Posted Mar 12, 2012 02:14 PM

    Hi guys,

    I have succesfully extended my iSCSI target with a second LUN. The LUN is visible in vSphere client 4.1, no problem. Still I can't extend the datastore, the "Increase" button is disabled. In KB article 1035285 :

    http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1035285

      ...I see two reasons for that, none of which applies: I have just one ESX v4.1 host, and the datastore is not on a snapshot LUN, it's on a "normal" LUN.

    At the very least I'd like to revert back to my single LUN, and just create a second datastore on the second LUN. I'm not sure it's possible though, now that the target contains two LUNs. I don't know if I can safely remove the second LUN.

    Thanks for any help,

    George



  • 2.  RE: Please HELP: cannot Increase datastore with new LUN

    Posted Mar 12, 2012 08:51 PM
    At the very least I'd like to revert back to my single LUN, and just  create a second datastore on the second LUN. I'm not sure it's possible  though, now that the target contains two LUNs. I don't know if I can  safely remove the second LUN

    I'm a little bit confused. You are saying the target (the storage system!?) presents two LUNs to the ESX host and you are unable to add the second LUN as an extent to the existing datatore (what I don't recommend unless there's a special requirement to do this) on the first LUN. In this case the second LUN should be still available in the "Add storage" wizard to create a datastore on it!? What I don't understand is from where you want to remove the second LUN in this case.

    André



  • 3.  RE: Please HELP: cannot Increase datastore with new LUN

    Posted Mar 12, 2012 09:15 PM

    Thanks for answering, Andre,

    Let me explain: my NAS is happy: the target contains both LUNs, the old one, 300GB, and the new one, 100GB.

    On ESX, the datastore that is associated with the target sees it as being only 300GB, i.e. the second LUN is not yet utilized. The extra LUN is seen as being available on the iSCSI server, but in order to utilize it, I have to use the "increase" function on the datastore. That's what I can't do: the increase button is disabled. The KB article I mentioned gives two reasons, none of which applies to me.

    If I can remove the 100GB second LUN without damaging the target (it contains about 10 guest VMs) and thus return to the initial state, then I'll happily settle with the second option of just creating a second datastore on that second 100GB LUN. But I don't know if that removal is a safe operation.

    I made an experiment, duplicating the above scenario with one test target and two test LUNs, but I used an XP machine as a client, not an ESX host. The second LUN was again not seen by XP, I'd probably need to reformat the partition that I had associated with the target. And of course when I removed the second LUN, the partition remained unaffected. But this is XP, not ESX.

    In case it matters, all work above has been done with the VMs up and running, i.e. the datastore is active.

    Again, I'm not determined to add the second LUN, all I need is to increase the available storage on my ESX host, so if this means "just create a second datastore and leave the first one as it is, with its initial single LUN", that's fine. But this means I must first detach the second LUN.



  • 4.  RE: Please HELP: cannot Increase datastore with new LUN

    Posted Mar 12, 2012 09:30 PM

    Sorry, I still don't understand why and from where you want to detach the new LUN.

    From what I understand:

    • 2 LUNs created on the iSCSI storage, first one 300GB second one 100GB
    • both LUNs are presented to the ESX host (on the storage side)
    • both LUNs are visible on the ESX host (Configuration -> Storage Adapter)
    • only one datastore exists (300 GB)

    If this is the case you should be able to create a second datastore (100GB) from Configuration -> Storage -> Add storage ...

    André



  • 5.  RE: Please HELP: cannot Increase datastore with new LUN

    Posted Mar 12, 2012 09:39 PM

    Andre,

    The second LUN is STILL attached to the target. The ESX host cannot see it though.

    As I wrote, I'll gladly use that second LUN (the 100GB) to create a second datastore on it, but don't I first need to detach it from the target that it's currently attached to?  (attached yes, but not successfully so in practical terms, since the ESX host still sees the datastore as 300GB, and the "increase" function that would let me extend the datastore to 300+100 GB is greyed out).

    Don't I first need to go back to the previous situation, where the target (datastore) only had ONE LUN, the 300GB one? And only then create a second datatore on the - now orphaned - second LUN of 100GB?



  • 6.  RE: Please HELP: cannot Increase datastore with new LUN

    Posted Mar 14, 2012 10:05 AM

    Andre, you evidently are my only hope for a solution.

    Please take another look.

    Currently on the NAS:   target1 --> LUN1 + LUN2  == 300GB + 100GB

    However, on the ESX:  datastore1 --> target1 --> 300GB --> only sees LUN1, and I can't "Increase" it to see the LUN2, because the button is greyed out.

    In order to  create a 2nd datastore on LUN2, as you suggest, don't I first have to remove LUN2 from target1, using my NAS tools?

    I know how I can do it, but can I do it safely?

    Thanks again!

    George



  • 7.  RE: Please HELP: cannot Increase datastore with new LUN

    Posted Mar 14, 2012 10:57 AM

    Which NAS system do you use (vendor and model)?

    In your first post you said that you can see the LUN and now you say you can't see it on the ESX host!? Which LUNs do you see when you select the vmhba adapter under Configuration -> Storage Adapters on the ESX host?

    André



  • 8.  RE: Please HELP: cannot Increase datastore with new LUN

    Posted Mar 14, 2012 11:06 AM

    Andre,

    In my NAS (Qnap)  the target is seen as containing both LUN1 and LUN2

    On the ESX host, the datastore that is associated with the target is seen only as 300GB, which means that the ESX host cannot - for now - see the second LUN2 as being part of the datastore.  LUN2 is seen, but as just a LUN, not associated with the datastore. The normal procedure now is to use the Increase button to force the datastore to see LUN2.

    Since I can't fix that by using the "increase" button (which as I've written is disabled), I want to drop this whole idea, and detach LUN2 from my target, using the NAS tools. I know how to do that (disable and then detach), my fear is that this might affect my target.

    Once I do that I'll be free to create a 2nd datastore on LUN2, no problem there.

    I hope that finally all is clear.