vCenter

 View Only
  • 1.  Only a portion of the disk gets converted

    Posted Nov 01, 2009 09:37 PM

    I am trying to virtualize a laptop running Windows XP SP3 using the vCenter Converter Standalone Client (4.0.1 build-161434). The laptop I'm trying to convert has 2 partitions with approximately 30GB of data. I have an external USB drive hooked up to store the output on and transfer it to the new host. If I run through with the default options the conversion fails during reconfiguration. If I deselect the reconfiguration options it succeeds...but doesn't work.

    I think I've tracked down the problem, but am stuck trying to find the cause. I know there is ~30GB of data on the disk, but no matter what I try the virtual disk it writes out is only ~10GB. I believe this explains why the reconfiguration fails...per the logs it can't open specific files from the virtual disk to change them, likely because they're not there, because they didn't get converted.

    I need the virtual disk to be as small as possible, so on Step 3 under Data to Copy I change each source volume from Maintain Size to Min Size.

    Attached are the log files from the two conversion attempts. They both have error in the last agent log (that I've found, there's probably more).

    Any idea why only a portion of the disk data would be converted?



  • 2.  RE: Only a portion of the disk gets converted

    Posted Nov 02, 2009 03:18 AM

    Update: Reran the conversion tool and left the disks set to maintain size instead of minimal size and everything worked just fine!

    Still not sure why it did what it did in the first place, and maybe VMware folks could look at clarifying what those options actually mean. The UI seems to indicate that maintaining the disk size would make a pre-allocated virtual disk, when it actually does not.