View Only
  • 1.  Networking lost after config restore on ESXi

    Posted Nov 24, 2021 06:09 PM
      |   view attached

    Hello community


    Today I had a strange issue after config restore with PowerCLI. I've done a lot of ESXi configuration restores in the past - used to work like a charm.

    The host rebooted and came up with restored settings (password, hostname, datastores) but the DCUI was blank (see picture). Login possible but no way to configure or check networking (grey).

    What I did:

    Host was migrated from 6.7 to 7 in the past, so the partitioning of the boot disk wasn't optimal for ESXi 7. Not a problem - just cosmetics.

    Host is part of a 4-node vSAN cluster in my homelab. I set it into maintenance mode (full data migration) and saved the configuration with PowerCLI [Get-VMHostFirmware -BackupConfiguration]. The way I did it many times before.

    Then I did a clean install with my latest VMware ESXi-ISO (same build as before).

    Host came up normally with an IP address from DHCP. I was able to connect a PowerCLI shell to the host, set it into maintenance mode and triggered a configuration restore. No problem so far.

    Host rebooted in a normal manner, but instead showing me hostname and IP address at the end it came up with a blank DCUI surface. I can login with the original password from the config. 

    esxcli network nic list -> shows all NICs in status up.

    esxcli network vswitch standard list  -> shows nothing.

    esxcli network vswitch dvs vmware list -> shows nothing either.

    Before I had Management Network on vSwitch0 (standard). There have been dvs for vMotion and vSAN-Network and also dvs (not N-VDS) managed by NSX-T (3.1).

    I also tried a config that I took a few days earlier, but same result.

    I haven't seen this before. Any ideas what might go on here?


    Thanks in advance


  • 2.  RE: Networking lost after config restore on ESXi

    Posted Nov 28, 2021 06:05 PM

    After doing some research I finally found the root cause of the problem.

    It sounds simple but it almost drove me nuts.

    I could reproduce the issue with 3 different configurations and corresponding ESXi builds. Finally it was missing NSX-T kernel modules on the fresh host that prevented a proper restore of the configuration.

    Details can be found here:

    I hope that'll help someone in the same situation.