vSphere vNetwork

 View Only
  • 1.  Nested ESX connectivity problem

    Posted Jan 17, 2011 10:11 AM

    hi, i'm new to the community so forgive me if i post this in the wrong place.

    i tried running ESX4.0 inside ESX 4.0 as a virtual machine. The installation went fine and the VM ESX was up and running. unfortunatelly, the VM esx has no network connectivity and fails even to ping the default gateway (192.168.0.1) our lan configuration is as follows:

    vlan 3 : 192.168.0.0/24 (internal users & green zone servers)

    vlan 2: 192.168.2.0/24 (DMZ)

    VM ESX service console: 192.168.0.15

    physicall ESX service console: 192.168.0.254

    the production VMs and service console are connected to vSwitch0 which is connected, via a physical NIC, to a cisco 2960 switch's gigabit port (the port runs as a trunk with vlan 2 as a native vlan)

    the service console of the physical ESX and the VMs that lie on network 192.168.0.0/24 are connected to vSwitch0 through port groups with VLAN ID set to 3.

    i tried VLAN ID 0 and 3 with the VM ESX's service console but i still couldn't access the network. i tried using a port group with no vlan id (0) and which uplink (physical NIC) is connected to an access port that belongs to VLAN 3, yet the ESX VM still failled to connect to the network

    i might've forgot to mention a few things needed to solve this problem, so don't hesitate and ask. attached is snapshot of my network configuration. ESX-2 (and ESX-2-2) are the mentioned VM ESXs



  • 2.  RE: Nested ESX connectivity problem

    Posted Jan 17, 2011 05:19 PM

    Virtual ESX requires promiscuous mode for its networking setup.  Is the portgroup or vSwitch configured for promiscuous mode?  See KB 1004099.



  • 3.  RE: Nested ESX connectivity problem

    Posted Jan 18, 2011 06:29 AM

    thanks...it's working now. could you please explain to me why i must use promiscuous mode to get it working? why it didn't work in the two scenarios?



  • 4.  RE: Nested ESX connectivity problem

    Posted Jan 18, 2011 06:38 PM

    I believe you need promiscuous mode because the vmknic uses a different MAC address than the "physical" NIC (which in this case is actually a virtual e1000).  However, I'm not a networking person, so take this explanation with a grain of salt.



  • 5.  RE: Nested ESX connectivity problem

    Posted Jan 18, 2011 07:22 PM

    You are right.

    The "host" ESX system does only know the MAC addresses of the virtual machines attached to it's port groups. Theses are the MAC addresses of the "guest" ESX system's uplinks (the E1000 configured for the ESX VMs). The MAC addresses of the VM's running on the "guest" system are only visible to the "guest" itself. Without setting promiscuous mode the "host" will only forward packets for the known MAC addresses to the associated ports.

    André



  • 6.  RE: Nested ESX connectivity problem

    Posted Jan 19, 2011 06:48 AM

    yes, it makes sense now...thanks for the both of you