vCloud

 View Only
  • 1.  mail error & no production mode

    Posted Oct 26, 2017 02:57 PM

    Hi.

    I have just installed a completely new installation of the vCloud Usage Meter 3.6.0.1 Build 6552112, but by the first configuration I got the following error message:

    Unable to send an email because of a non-existing recipient email address.

    I can't go ahead because with this error I can't klick on save.

    I have already tried to reinstall the Usage Meter again. But then I got the message, that the Usage Meter is not in the production mode.

    1. How can I change the test mode into production mode?

    2. How can I resolv the mail problem? There is no possibility to enter an receipent email address and my email address on the first page is correct.

    Thanks, best regards



  • 2.  RE: mail error & no production mode

    Broadcom Employee
    Posted Oct 26, 2017 03:24 PM

    Hi,

    Please configure an outgoing email server, so that vCloud Usage Meter can send emails.

    Reference doc : Configuring Email Settings

    Steps to be followed,

    In Email Page,

    1. Provide SMTP Host details.

    2. Clicks Send Email button.

    Thanks,

    Vinayaga.



  • 3.  RE: mail error & no production mode

    Posted Oct 27, 2017 06:01 AM

    Hi,

    thanks for the answer. But here is the problem: When I click the button "send email" I get the error message.

    regards



  • 4.  RE: mail error & no production mode

    Broadcom Employee
    Posted Oct 27, 2017 07:41 AM

    Hi,

    • Could you please confirm, whether your SMTP server has permission to send emails to outside network (VMware)?

    If you are configuring a vCloud Usage Meter instance in an environment with no access to Internet, consider the following best practices:

    • Make sure that your mail server can relay messages from the service provider email address, using either authenticated or unauthenticated SMTP.
    • If your mail server requires authentication, use encryption.
    • Verify the SMTP port number that is assigned to your mail server.

    Thanks,

    Vinayaga.



  • 5.  RE: mail error & no production mode

    Posted Jun 01, 2018 09:27 AM

    I have the same problem in build 7359407. It won't let me save mail server until it has succeded in sending email. It can't send send email until recipient is configured but it won't let me configure recipient until mail server is configured! Assuming recipient email address configuration is under "Email Alerts" that is greyed out,



  • 6.  RE: mail error & no production mode
    Best Answer

    Posted Jun 01, 2018 10:02 AM

    Wireshark to the rescue. Email is sent to the address configured on the provider tab and also to um-reports@vmware.com so it needs relay permission to vmware.com



  • 7.  RE: mail error & no production mode

    Broadcom Employee
    Posted Jun 01, 2018 10:18 AM

    Hi,

    In Usage Meter, Please do Configure the Outgoing Email Server settings. (Manager--> Email).

    To send emails to VMware, it is mandatory to configure host name and port number (default: 25).

    Steps to be followed,

    1. In Manage-->Email Page,
    2. Provide valid SMTP Host server details.
    3. To verify the email settings, click Send email.
    4. (Optional) If necessary, select Connection Security from the drop-down.
    5. (Optional) If you require authentication for the outgoing email server, enter a User name and Password.
    6. Click Save.

    Note:

    In case of wrong configuration of SMTP host, Usage Meter throws an error message "Unable to send an email because of either wrong configuration of SMTP host or network error. Please update Outgoing Email Server settings or check your network settings.".