Backup & Recovery

 View Only
  • 1.  lost datastore

    Posted Oct 02, 2020 04:11 AM

    Hi Expert,

    i powered down a vm trying to move to another datastore. but all the sudden after shutting down the vm, the datastore is just disappeared right in front of me & the vm showed inaccessible.

    this datastore is a dell MD1200 storage connected to PERC 800.

    i rebooted the host & looked like the controller card is bad. & got stuck in rebooting until i removed the PERC 800 card

    i connected the cable to another host which has the same PERC 800 card but it showed the size of the storage 20TB and available size is also 20TB. it means every is gone inside. 

    is there any way to recover the lost vm inside?

    is diskinternal going to help?

    Thanks

    Joe



  • 2.  RE: lost datastore

    Posted Oct 02, 2020 06:28 AM

    is delete the current partition table & recreate another one with the original disk id helpful? i tried plugged into a windows machine & scanned with diskinternal & i did see some big files like vmdk but with random names.



  • 3.  RE: lost datastore

    Posted Oct 02, 2020 10:58 AM

    On the other Host be sure that you "import" the RAID config within the H800 by looking if there is a "foreign" one.

    Please run

    esxcfg-volume -l

    from ESXi commandline than.

    Regards,
    Joerg



  • 4.  RE: lost datastore

    Posted Oct 02, 2020 05:35 PM

    thanks Joerg.

    on the other host, i did the import from Foreign. but it gave me another disk id & showed 100% capacity. it should be 50% space has been used.

    i ran the command

    [root@VM3:~] esxcfg-volume -l

    VMFS UUID/label: 5f75a69a-81578dcd-21a0-001e4f1caa5e/datastore4

    Can mount: Yes

    Can resignature: Yes

    Extent name: naa.690b11c000ce33002708d7570b70af91:1     range: 0 - 22888191 (MB)

    [root@VM3:~]

    so far i have nothing write into the storage. i also attached it to a windows machine scanned with diskinternal. it did find files inside but with random name.

    Joe



  • 5.  RE: lost datastore

    Posted Oct 02, 2020 12:19 PM

    looked like the controller card is bad.

    What's the error of storage controller?! What does it show? How did you understand the status of that controller?



  • 6.  RE: lost datastore

    Posted Oct 02, 2020 05:39 PM

    the error on the original host while rebooting: LSI EFI SAS Driver: Unhealthy status reported by this UEFI driver without specific error. UEFI0116: one or more boot drives have reported issue(s).

    so the host refused to boot until i removed the storage & controller card



  • 7.  RE: lost datastore

    Posted Oct 02, 2020 05:54 PM

    STTTTTOOOOOOP!

    "VMFS UUID/label: 5f75a69a-81578dcd-21a0-001e4f1caa5e/datastore4"

    Your Datastore is there! Please run

     esxcfg-volume -M datastore4

    Maybe someone can explain if the "Extent name" information is normal because i cant remember to it when i have to deal with snapthot LUNs.

    If you have attched this Volume to a MS Server and initialize it in the meantime than your data is gone away... well than you a specialist and not me.

    Regards,
    Joerg



  • 8.  RE: lost datastore

    Posted Oct 02, 2020 06:15 PM

    it mounted the volume. but empty inside. all data are gone.

    when i connected it to a windows machine, i did not initialize it. windows can see the controller card & the storage attached. diskinternal also see storage & able to scan it & found files looks like virtual disks.

    thanks

    Joe



  • 9.  RE: lost datastore

    Posted Oct 02, 2020 06:23 PM

    Try to contact continuum​ via Skype (see his profile). He's likely the only one here on VMTN who might be able to help.


    André



  • 10.  RE: lost datastore
    Best Answer

    Posted Oct 02, 2020 10:23 PM

    thanks for all the support!

    finally i decided to use diskinternals & it recovered all the lost data for me!