VMware vSphere

 View Only
  • 1.  Locker folder issue

    Posted Oct 05, 2018 06:55 PM

    Hello,

    I'm in the process of upgrading 5 vSphere 6.5 U1 hosts to vSphere 6.7. 4 of them went well, the 5th shows a problem.

    After a failed upgrade it shows: 'Cannot execute upgrade script on host.'

    So I started putty and 1 store was 100% in use. Each time it's the locker store. I found articles to clean up the store. I did, even back 99% free, but till now still no luck.

    I noticed some strange behavior of this store: when running 'ls -l' a nice listing shows.

    [root@MY-ESX03:/vmfs/volumes/584ec949-400c0a6f-ed9d-001f295dea86] ls -la

    total 2048

    drwxr-xr-x    1 root     root             8 Jan  1  1970

    drwxr-xr-x    1 root     root             8 Jan  1  1970

    drwxr-xr-x    1 root     root             8 Jan  1  1970

    drwxr-xr-x    1 root     root             8 Jan  1  1970

    drwxr-xr-x    1 root     root             8 Jan  1  1970

    drwxr-xr-x    1 root     root             8 Jan  1  1970

    drwxr-xr-x    1 root     root           512 Oct  5 18:45 ..

    drwxr-xr-x    1 root     root             8 Oct  5 13:43 packages

    drwxr-xr-x    1 root     root             8 Oct  5 13:43 var

    [root@MY-ESX03:/vmfs/volumes/584ec949-400c0a6f-ed9d-001f295dea86]

    But when I use 'ls -R'

    [root@MY-ESX03:/vmfs/volumes/584ec949-400c0a6f-ed9d-001f295dea86] ls -R

    .:

    packages  var

    ./:

    packages  var

    ./:

    packages  var

    ./:

    packages  var

    ./:

    packages  var

    ./:

    packages  var

    I have to use CTRL-C to stop it....

    On every other host this runs nicely and stops all by itself.

    Anyone seen this behavior?

    And if so: do you have a solution?

    Kind regards,

    René



  • 2.  RE: Locker folder issue

    Posted Oct 06, 2018 02:47 PM

    You might have done it already but, have you restarted the management agents on the host after freeing up the concerned partition?

    Cheers,

    Supreet



  • 3.  RE: Locker folder issue

    Posted Oct 06, 2018 09:09 PM

    Thank you for your suggestion.

    I've even restarted the host directly afterwards, but no luck.

    Regards,

    René