vCenter

 View Only
  • 1.  JBoss deployment failure

    Posted Mar 20, 2009 01:22 PM
    I am new to hyperic. I just started trying to play with it a couple days ago, so I apologize ahead of time if I leave pertinent info out.

    I installed the hq server, using all defaults and the built in db. I am running JRE1.6_12 on RHEL5. I got through all the install steps until where you actually start the hq server. When I run the command to start (./hq-server.sh start) it gets part way in and then errors out with:

    ERROR [MainDeployer] Could not create deployment: file:/home/hyperic/server-4.1.0/hq-engine/server/default/conf/jboss-service.xml

    I have no clue where to go from here. Hopefully somone out there does, otherwise, this will probably go to the "too hard" category and we'll move on to testing the next monitoring solution.


  • 2.  RE: JBoss deployment failure

    Posted Mar 20, 2009 06:28 PM
    I have found that if I do a nc -k -l 7080 in one terminal and then start the server in another, it will boot. I still cannot hit the url though of http://127.0.0.1:7080.


  • 3.  RE: JBoss deployment failure

    Posted Mar 20, 2009 07:46 PM
    Is there anything else running on the system besides HQ Server and the database? Does the server.log just end on the deployer error?


  • 4.  RE: JBoss deployment failure

    Posted Mar 23, 2009 01:00 PM
    The error log continues on for a while but it's all Caused by: ..... Like I said, I am new, so I asked another developer to look at the log and he told me that I needed to look at the error and not all the "caused by" entries.

    Nothing else is running on the system.


  • 5.  RE: JBoss deployment failure

    Posted May 26, 2009 06:26 PM
    If running on linux, please check your hosts file on /etc/hosts.
    See if contains your hostname with FQDN, try it pointing to 127.0.0.1 or your ip address.

    Worked for me.