vCenter

 View Only
  • 1.  How to clear a PID conflict on Solaris HQ-Server

    Posted Apr 01, 2007 05:18 AM
    Hey folks, the title says it all. I have installed HQ-Server on a solaris box. I started it the first time, everything looked good. I stopped it so I could make some minor configuration changes (localhost to ip address in the conf files), then tried to start the server again, but got this error
    HQ server is already running (pid 986).

    the pid is not listed in ps or top or lsof.

    is there a file I couldn't find with grep that contains the pid? Is the PID stored in the dB?. if so how do I clear it?

    Thanks,

    Deeboh


  • 2.  RE: How to clear a PID conflict on Solaris HQ-Server
    Best Answer

    Posted Apr 02, 2007 08:28 PM
    The server pid file is kept in [server_install_directory]/logs/hq-server.pid. The server start-up should detect whether or not this pid is stale, and respond accordingly.

    I could see this breaking if you started the server as one user (like root), and then tried to restart it as another user (like hyperic) where that second start did not have the permissions to over-write/remove the old pid information.