View Only
  • 1.  HA no active primaries found

    Posted Oct 17, 2008 01:40 PM


    When i am trying to configure my four esx servers for HA, always one of them shows this error messages: no active primaries found. I tried reboot, create new cluster. Always i get this message. What i noticed that three esx servers has storage named "NAS" , esx4 has NAS (1). But i cant change it to NAS, it saying that this name is already exist in datacenter. I changed it by connecting directly to esx serve. But when i returned to virtualcenter that storage was still NAS (1). I tried to remove and then add storage again. Always its getting that same name NAS (1). How to solve this problem?

  • 2.  RE: HA no active primaries found
    Best Answer

    Posted Oct 17, 2008 02:07 PM

    That sounds like two different problems.

    For the first, make sure in your hosts file that the name is all lower case, and make sure your name resolution works for both the long name and the short name of the hosts.

    For the second, I assume you're using NFS as opposed to local storage. Remove the mount and make sure vc sees the stoarge as gone before re-adding. Your VC may be holding on to the name from a previous mount, and therefore not allowing a new mount with the same name.


  • 3.  RE: HA no active primaries found

    Posted Oct 20, 2008 08:43 AM

    thank you. ha agent problem was in name resolution. it fixed.

    For the NFS storage identification name i cant fix it. the problem is when i am trying migrate vm from different esx host to this esx host where nfs storage identification is different, migration wizard sees it as different storage and i can only choose this option "move virtual machine configuration files and virtual disks".

  • 4.  RE: HA no active primaries found

    Posted Oct 20, 2008 08:46 AM

    problem was solved. I wrote different path in NFS volume. "/VMWARE" != "VMWARE"