View Only
  • 1.  Guest issue on ESXi 4

    Posted Aug 29, 2013 12:28 AM

    Hey all.. looking for some assistance. Client has a physical server with just one SBS 2008 VM. We replaced a failed drive in a local RAID5 (the only storage) which went fine. About two hours later we noticed the VM was very slow and we couldn't fully RDP into it (session opened but desktop would not load). We had to power it off and we rebooted the host. The host hung at a red kernel panic and none of the drives were lit up. What's weird is we can pull the power, what five mins, plug in power and the drives come alive and ESXi boots fine. Once up all hardware reports OK and the datastore is accessible. We can even create a new folder, delete files, etc. However, when we tried to start the VM initially we got the following error:

    "Failed to power on VM
    Could not power on VM : Invalid metadata."

    Per a VMware KB, we set a memory reservation equal to the amount or RAM on the VM and it powers up. Except it sits at black screen with a curser in the upper left corner.

    If we remove the disks to VM powers on and goes to OS not found which of course is expected.

    My first thought was something is something got corrupt with the VMDK. However, if I try and create a new VM on the local VMFS datastore I get:

    "A general system error occured: Error creating disk Invalid argument"

    We have a laptop attached running Ubuntu serving up a temp NFS store. I can create a new VM to that without issue. So I am not sure if the issue is actually the VMDK, the local datastore, or both. Any ideas? Suggestions for moving forward?


  • 2.  RE: Guest issue on ESXi 4

    Posted Aug 29, 2013 02:43 AM

    Try moving the VM to a different LUN and see if gets powered ON. and you could also check the VMkernel logs that could point us to the bottleneck.

  • 3.  RE: Guest issue on ESXi 4

    Posted Aug 29, 2013 02:36 PM

    Moving the VM files fails with en error

  • 4.  RE: Guest issue on ESXi 4

    Posted Sep 02, 2013 08:43 AM

    Is by any chance your server is a DELL having PERC RAID... and most important, is your RAID config with BATTERY supported.? If yes, then what I am suspecting is that when the RAID was rebuilding and you had rebooted the host, the cache was flushed and was not written. Check here VMware KB: VMware ESX 4.0, Patch ESX400-200907401-BG: Updates vmklinux and vmkernel64

    Regd .your client SBS vm, I suspect the vmdk is corrupted. We need to work on recovering it, unless if you have snapshots which would make it easier. Else, check if the RAID is rebuilded successfully, then clone the VM to another test vm and power on the test vm to confirm operation


    "A general system error occured: Error creating disk Invalid argument"

    It is a command line syntax error. Post out the command you tried. Let me see if we can fix it.

  • 5.  RE: Guest issue on ESXi 4

    Posted Sep 03, 2013 02:27 AM

    Well we did end up having to use Kroll Ontrack to get back the VMDKs.. they were intact, luckily. But it wasn't cheap ($12k) since we had to use their emergency service level given the long holiday weekend and the fact the client had already been down a few days.

    The VMDKs were as follows for those curious..

    C: 60GB
    D: 40GB
    E: 200GB

    Learn from this and ALWAYS check those backups before any hardware change. :smileyhappy: