ESXi

 View Only
  • 1.  Ghosted iSCSI Static Target cannot be removed

    Posted Jan 06, 2012 02:36 PM

    Hi,

    I've got a very very strange problem. I have a bogus iSCSI target entry on one of the hardware iSCSI initiators.

    <code>

    ~ # vmkiscsi-tool -S vmhba4
    STATIC DISCOVERY TARGET
       NAME     : iscsi
       ADDRESS  : 192.168.198.254:3260
    ~ # vmkiscsi-tool -S vmhba4
    STATIC DISCOVERY TARGET
       NAME     : iscsi
       ADDRESS  : 192.168.198.254:3260
    </code>

    As you can see the target name is iscsi, which should be a full IQDN. When i try to remove the entry via GUI and CLI, it states that it has been removed succesfully. But when going to the CLI and populate the target list, the entry is still there. I have completely reinstalled the HP BL485 G7 blade with ESXi (5.0), but the entry is still there... yes, still there. I think it's cached somewere in the iSCSI hardware controller.

    I've configured the networking via HP Virtual Connect with two Flex-10 interconnects. I use the onboard LOMS, Emulex FlexFabruk One Connect.

    - LOMa-1: 5GB / Production & Management

    - LOMb-1: 5GB / Production & Management

    - LOMa-2: 2GB / vMotion

    - LOMb-2: 2GB / vMotion

    - LOMa-3: 3GB / iSCSI

    - LOMb-3: 3GB / iSCSI

    Things tried:

    - Delete iSCSI DB: vmkiscsid.db
    - Re-installed ESXI, formatted the disk

    - Checked for latest Oneconnect firmware. I'm on OneConnect-Flash-4.0.360.20

    Any input is very welcome.

    Kind Regards,

    Bastiaan



  • 2.  RE: Ghosted iSCSI Static Target cannot be removed

    Posted Jan 11, 2012 10:29 AM

    Hi,

    Are you using Dynamic Discovery in the iSCSI Initiator Properties?

    Could is be possible that the "Bogus" IP Address is automatically populated by the storage array?

    Can you provide the output of the following command?

    vmkiscsi-tool -T vmhba4

    Also, do you have version 4.0.317.0 of Emulex be2iscsi driver installed?

    http://downloads.vmware.com/d/details/dt_esxi50_emulex_oce11100_403170/dHRAYnRqdCViZHAlJQ==



  • 3.  RE: Ghosted iSCSI Static Target cannot be removed

    Posted Jan 17, 2012 08:33 AM

    Hi, thank you for your reply.

    I removed the dynamic discovery IP's. But still this bogus iscsi target is populated.

    I can't see how this bogus target is populated from the sotrage array, non of the other hba's get it while the access is the same.

    When running the command "vmkiscsi-tool -T vmhba4" i get something weard:

    ~ # vmkiscsi-tool -T vmhba4
    Error: Bad Parameter for the API

    Error: Bad Parameter for the API

    Error: Bad Parameter for the API

    Error: Bad Parameter for the API

    Error: Bad Parameter for the API

    Error: Bad Parameter for the API

    Error: Bad Parameter for the API

    Error: Bad Parameter for the API

    Error: Bad Parameter for the API

    When running it on the other vmhba3 the output is correct.

    I have the latest drivers & firmware's installed.

    Any help is welcome...



  • 4.  RE: Ghosted iSCSI Static Target cannot be removed

    Posted Jan 21, 2012 02:13 PM

    Hi,

    Is it just one host that you are experiencing this issue with?

    If that is the case, as a last resort, you might want to try reinstalling ESXi using the HP customized image.

    An HP Customized build of VMware ESXi 5.0 is available for download here: (free registration required)

    https://h20392.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=HPVM09



  • 5.  RE: Ghosted iSCSI Static Target cannot be removed

    Posted Jan 23, 2012 07:34 AM

    Thank you for your reply.

    I've managed to fix the issue with the help of support. They pointed me to look into the BIOS of the HBA card. There i found the bogus target in the iSCSI target list. When configuring targets in ESX they get pushed via the Emulex driver into the HBA card, so you can use them to boot of. Somehow something got wrong when the driver pushed a bogus entry into the HBA card. And ESX was not able to remove it again because the entry was not compliant with a iSCSI iqdn.

    So solution: boot into the HBA card bios via CTRL-S and remove the iSCSI target there.