View Only
  • 1.  Get-Stat -interval not working for host CPU

    Posted Oct 04, 2021 12:57 PM


    I have an issue with Get-Stat -interval option. When quering host for cpu.usage.average and mem.usage.average for last month (atleast 30+ days) it returned values for each day (1 day 1 value, anything less than 30 days and it returns values for every 4 hours so to make things simple I usually do 30+days).

    The issue is that for mem.usage.average it works fine, however it seems broken for cpu.usage.average.

    For every day there are ~98 data points, timestamp does not change the data and is the same for all the points, only values are changing. Tried to apply different -intervalmins, secs values but with no effect.


    Used the script last month with no issues, only thing that has changed is that we applied newest security patches to our vCenter. Any ideas? Can't figure out how to solve this.





  • 2.  RE: Get-Stat -interval not working for host CPU
    Best Answer

    Posted Oct 04, 2021 01:05 PM

    Did you check the Instance property for all those entries?

  • 3.  RE: Get-Stat -interval not working for host CPU

    Posted Oct 04, 2021 01:37 PM

    Thank you  , it did the trick! What I did is set -Instance "" for it to return average for all cores, thanks.

    I tried to run the command without the Instance and oddly enough it still works there, only change is that the test server has a statistics level of 1 whereas prod is set to 3.