VMware vSphere

 View Only
  • 1.  Firstboot Failed during Install

    Posted Oct 14, 2022 01:07 PM

    Hi ,

    I am trying to deploy Vcenter 8.0.

    I am getting Firstboot Failed during Install.

    The below is the log:

    Traceback (most recent call last):
    File "/usr/lib/vmware-vlcm/firstboot/vlcm_firstboot.py", line 167, in <module>
    main()
    File "/usr/lib/vmware-vlcm/firstboot/vlcm_firstboot.py", line 129, in main
    fb = VlcmFirstboot(VLCM_COMP, VLCM_SOLUSERNAME)
    File "/usr/lib/vmware-vlcm/firstboot/vlcm_firstboot.py", line 50, in __init__
    os.path.join(get_install_parameter('upgrade.import.directory'), "vlcm")
    File "/usr/lib/vmware/site-packages/cis/tools.py", line 88, in get_install_parameter
    raise InstallParameterException('Install-parameter %s not set' % param)
    cis.exceptions.InstallParameterException: {
    "detail": [
    {
    "id": "install.ciscommon.internal.error",
    "translatable": "Encountered an internal error.\n\n%(0)s",
    "args": [
    "Install-parameter upgrade.import.directory not set"
    ],
    "localized": "Encountered an internal error.\n\nInstall-parameter upgrade.import.directory not set"
    }
    ],
    "componentKey": null,
    "problemId": null,
    "resolution": {
    "id": "install.default.failure.resolution",
    "translatable": "This is an unrecoverable error, please retry install. If you encounter this error again, please search for these symptoms in the VMware Knowledge Base for any known issues and possible resolutions. If none can be found, collect a support bundle and open a support request.",
    "localized": "This is an unrecoverable error, please retry install. If you encounter this error again, please search for these symptoms in the VMware Knowledge Base for any known issues and possible resolutions. If none can be found, collect a support bundle and open a support request."

    Has anyone encounter this problem and has the fix for it?

    Thank you.

    Chris.

     

     

     

     

     



  • 2.  RE: Firstboot Failed during Install

    Posted Oct 31, 2022 03:09 PM

    Same issue.. Fighting third day. 



  • 3.  RE: Firstboot Failed during Install

    Posted Nov 27, 2022 09:09 PM

    Exact same problem here too, on a fresh install with a single esxi host.



  • 4.  RE: Firstboot Failed during Install

    Posted Nov 27, 2022 10:13 PM

    a few days ago we have installed vCenter 8.0 

    there were no issues



  • 5.  RE: Firstboot Failed during Install

    Posted Nov 27, 2022 10:42 PM

    On another attempt, this time I followed these instructions:

    https://williamlam.com/2022/10/how-to-deploy-the-vcenter-server-appliance-vcsa-8-0-to-vmware-fusion-or-workstation.html

    The general steps were to convert the .ova to .ovf, make the change (set property "guestinfo.cis.upgrade.import.directory" to ovf:userConfigurable="true"), and convert it back to ova. Then run the installer.

    This worked for me. (To be clear, I'm not using fusion/workstation, and I'm not "upgrading." This is the simplest possible case of a fresh install onto a single esxi host using just esxi directly.)



  • 6.  RE: Firstboot Failed during Install

    Posted Nov 28, 2022 06:45 AM

    Hi, 

    In my case suggested conversion ova to ovf and edit was not help full. 8.0 still failing at same place.

    After couple of days of fighting i gave up, installed version 7 without problems and did upgrade to 8.0. Upgrade procedure worked without errors.

    hope it help.

    A.