VMware vSphere

 View Only
  • 1.  F5 Tagged VLAN on trunk not working on 6.7U2

    Posted Apr 15, 2019 04:33 PM

    I just upgraded my lab ESXi and Vsphere appliance to 6.7U2 and since the upgrade I'm having an issue with my F5 load balancers.

    I am using a standard Vswitch and have setup the port group to allow all vlans (4095) however the tagged traffic on the VM is not leaving the VM.

    Even when running a tcpdump on the F5 on that interface, I don't see any traffic.  I am not even able to see my standby F5 that is on the same port group, no l2 or l3 traffic will pass.

    I have some other VMs on the same vlan (220) however the port group they are on is just for VLAN 220 and they all work fine.  They can talk to each other but they cannot talk to the F5 which is on the same vswitch.

    I also tried to create a new trunked port group with the same settings and moved the F5 to this port group with no luck.

    Has anyone else run into this issue?  Any other troubleshooting steps I can take?



  • 2.  RE: F5 Tagged VLAN on trunk not working on 6.7U2

    Posted Apr 16, 2019 05:46 AM

    I have  a similar configuration ( a Vm with guest tagging enabled) and its able to ping to another VM with same guest vlan tag.  The configuration is a newly deployed 67u2 configuration.

    What was your previous vc and esxi version from where it was upgraded to 67u2? I am planning to upgrade some other deployment to 67u2.

    Have you tried with any other VM with guest tagging enabled other than F5 load balancer  vm ?



  • 3.  RE: F5 Tagged VLAN on trunk not working on 6.7U2

    Posted Apr 16, 2019 11:46 PM

    Don't have anything substantive to add other than confirm the same problem with two F5 pairs here. Fortunately, realised before having upgraded all esxi hosts so vmotioned the F5's over and they resumed working. Hopefully a fix is forthcoming soon  :smileyhappy:



  • 4.  RE: F5 Tagged VLAN on trunk not working on 6.7U2

    Posted Apr 17, 2019 09:39 AM

    I am planning to upgrade 67u1 deployment to 67u2. I have normal linux VM with guest vlan tagging enabled. Have you seen this issue on all guest vlan tagged VM or only on F5 VM's?



  • 5.  RE: F5 Tagged VLAN on trunk not working on 6.7U2

    Posted Apr 17, 2019 03:38 PM

    I haven't tried with linux hosts yet, I'll give that a try... but from the sounds of it this may be a F5 issue?

    My F5 VMs are using VMXNET 3 adapters.

    Also I thought about upgrading the VM Hardware version from 14 -> 15 but this doesn't seem to work?  It says the VMs are up to date at 14 however I can create new VMs with v15.

    Anyone else notice that too?



  • 6.  RE: F5 Tagged VLAN on trunk not working on 6.7U2

    Posted Apr 23, 2019 04:43 AM

    I spun up a vanilla debian VM today and confirmed tagged vlan works fine. I used vmware hardware v10 to match my F5's. So seems like an F5 problem?



  • 7.  RE: F5 Tagged VLAN on trunk not working on 6.7U2

    Broadcom Employee
    Posted Apr 23, 2019 06:00 PM

    It looks like F5 VE is not supported for ESXi 6.7 U2 currently:

    "ESXi 6.7 Update 2 is not currently supported."

    BIG-IP Virtual Edition Supported Platforms



  • 8.  RE: F5 Tagged VLAN on trunk not working on 6.7U2
    Best Answer