ESXi

 View Only
  • 1.  Esxi4 + iSCSI crash test trouble

    Posted Mar 03, 2010 12:18 PM

    So,

    I Use ESXi4 + iscsi datastore flawlessly.

    But today I Tried a crash test.

    So in Vsphere Client, I delete(disconnect) the Datasore and next I removed the iSCSI adapter. Exactly what It would happened if my ESXi server crash and I must reinstall from scratch.

    Next I re-create an iSCSI adapter from my iSCSI Target : ok

    I connect a new Datastore based on my iSCSI adapter, but the proble is there : I can't just mount my "old" iscsi volume, it always wants to create new formated volume!!!!

    So how could I, only, mount my existing iscsi volume ?

    Thanks for kind help

    Items Used :

    ESXi4

    Vsphere Client

    Starwind Free with virtual hard disk volume



  • 2.  RE: Esxi4 + iSCSI crash test trouble

    Posted Mar 03, 2010 12:56 PM

    How did you "disconnected" the datastores? If you right clicked it and choose to remove it, you deleted the contents of the datastore.

    Marcelo Soares

    VMWare Certified Professional 310/410

    Technical Support Engineer

    Globant Argentina

    Consider awarding points for "helpful" and/or "correct" answers.



  • 3.  RE: Esxi4 + iSCSI crash test trouble

    Posted Mar 03, 2010 01:09 PM

    Yes I did this, Interesting quote !

    So how Could I "proper" disconnect a Datastore ?



  • 4.  RE: Esxi4 + iSCSI crash test trouble

    Posted Mar 03, 2010 01:13 PM

    :smileyhappy: ... not this way. Check this: http://kb.vmware.com/kb/1015084

    Marcelo Soares

    VMWare Certified Professional 310/410

    Technical Support Engineer

    Globant Argentina

    Consider awarding points for "helpful" and/or "correct" answers.



  • 5.  RE: Esxi4 + iSCSI crash test trouble

    Posted Mar 03, 2010 01:42 PM

    Really interesting elements.

    I read all and I got a question :

    It seems that it's more a masking process than a unmount one ?

    So If I applied this process, my LUN will be masked for my Host, isn't it ?

    So When I would try to make a new Datastore with my iscsi target (not Multipath one) it won't run properly because he's hide but still there, isn't it ?

    Thanks Marcelo for you already helpful answers.



  • 6.  RE: Esxi4 + iSCSI crash test trouble
    Best Answer

    Posted Mar 03, 2010 01:52 PM

    You will be able to add it again, because you will delete the claimrule masking the LUN at the end.

    You also can unpresent the LUN at the storage side, but this is the rightest way to do the operation.

    Marcelo Soares

    VMWare Certified Professional 310/410

    Technical Support Engineer

    Globant Argentina

    Consider awarding points for "helpful" and/or "correct" answers.



  • 7.  RE: Esxi4 + iSCSI crash test trouble

    Posted Mar 03, 2010 02:03 PM

    Great !

    I make a try.