ESXi

 View Only
Expand all | Collapse all

ESXi on DELL R710 Network Problems

  • 1.  ESXi on DELL R710 Network Problems

    Posted Oct 12, 2011 11:30 AM

    Hi,

    I am new to this so please be patient....

    I in the process of installing ESXi 5.0 onto a brand new DELL R710. The build is as follows:

    16GB RAM

    PERC H700 RAID Controller

    6 x 2TB HDD RAID6

    4 x NIC (2 Active)

    Static IP set 192.168.100.201

    The installation appears to complete without incident. We can ping the NIC IP Address from the network and open DELL iDRAC6 no problem. However:

    1. Open Management Console on the machine (F2 + Password)

    2. DHCP IP Address not received

    3. Manually set IP address (2 NIC same address), SN, GW and DNS server (only 1)

    4. Save configuration

    5. Test Network Settings --> NIC 1 Fail, NIC 2 Fail, Local Host Fail

    Re-check external ping from network, Ping OK.

    Re-check iDRAC connection, open page OK

    Does anyone have any ideas why ESXi is not able to see or be seen by the network?

    Thanks for any help you can provide.

    Mark



  • 2.  RE: ESXi on DELL R710 Network Problems

    Posted Oct 12, 2011 11:41 AM

    Hi, is the ping response your getting the IP of the Host or guest? do the network ports show in the Guest OS? 



  • 3.  RE: ESXi on DELL R710 Network Problems

    Posted Oct 12, 2011 11:51 AM

    Hi,

    The ping response is to the host. We have not loaded any guest OS into the machine yet. 



  • 4.  RE: ESXi on DELL R710 Network Problems

    Posted Oct 12, 2011 11:52 AM

    Hi Again,

    We are using ESXi as the host so have not gotten past that stage yet.



  • 5.  RE: ESXi on DELL R710 Network Problems

    Posted Oct 12, 2011 12:01 PM

    i have found that once you install the guest OS then it should pick up DHCP by default, just be careful and don't set the network card in ESXI to passthru, i made that mistake once as you lose connectivity to ESXI as it wont see the physical adaptor



  • 6.  RE: ESXi on DELL R710 Network Problems

    Posted Oct 12, 2011 12:54 PM

    Hi Dave,

    Thanks we will try that. I assume that the host ESXi install can maintain a static IP without problem.

    Thanks again.



  • 7.  RE: ESXi on DELL R710 Network Problems

    Posted Oct 12, 2011 12:59 PM

    yes, if you have specified a static IP when logging onto the Host from the root console then that will be the IP that you can then connect too using the client console



  • 8.  RE: ESXi on DELL R710 Network Problems

    Posted Oct 12, 2011 01:03 PM

    Hi Again,

    Having said that, we can't connect with vSphere Client so how would we create a new VM to load the guest OS onto?

    Sorry as noted at the beginning we are new to this.

    Thanks!



  • 9.  RE: ESXi on DELL R710 Network Problems

    Posted Oct 12, 2011 01:08 PM

    does the client just not try to connect or do you get an error? normally you'd set the static IP from the root console and set the login information, then using the vsphere client point it to the IP you set in the console, when you had said that you set a static IP where did you set that? also are the NICs 2 onboard and 2 on a card?



  • 10.  RE: ESXi on DELL R710 Network Problems

    Posted Oct 12, 2011 01:19 PM

    The Client tries to connect to the IP address. Rather than calling up ESXi, it tries to access iDRAC console on the DELL machine. I have checked and iDRAC is supported under ESXi 5.0 so we had assumed it would be transparent but apparently not. If we open the allocated IP in IE it returns the iDRAC GUI. From there we are able to access the DELL console and manipulate all machine features.

    We also were wondering at one point whether iDRAC needed a separate IP address to the ESXi host IP but that was no good either. Attempting to connect to the newly allocated ESXi IP address simply times out and we cannot ping that address so we assume that the iDRAC address must be the same as that used by ESXi.

    As previously noted, we can ping the address itself through the network from remote machines. However locally on the server machine, although the ESXi host recognises the NIC cards (and also identifies they are connected), a network test from the host console returns fail messages on the IP address itself.

    Kind of frustrating as the software loaded into the server machine and no errors reported so nothing to report back as being a problem. We even downloaded the customised DELL version of ESXi 5.0 with latest drivers and installed over the top (re-write datastore etc) but no luck.....

    Any ideas?



  • 11.  RE: ESXi on DELL R710 Network Problems

    Posted Oct 12, 2011 03:04 PM

    i would say that the static ip that you have given for the iDRAC is a bit like iLO, when you installed Esxi did configure it with a static ip address? it sounds like when your pinging the static ip that it may be the ip for the iDRAC rather than the ESXi host,  what you should have on the screen for esxi is a black and yellow screen which should show the IP that is assigned to it, if you press F2 then you should be able to log into it and configure the IP (making it differant to the static ip assigned to the iDRAC) you should then be able to connect using the vsphere client to the static ip



  • 12.  RE: ESXi on DELL R710 Network Problems

    Posted Oct 12, 2011 03:26 PM

    Hi,

    So the iDRAC and ESXi IP addresses need to be different then? When we did the initial install, the software installed no problem but returned a null IP address and 0.0.0.0 gateway with a message that could not obtain DHCP information. That is when we changed to static. I will try again tomorrow with a different static IP set for the ESXi install and iDRAC and see how that goes. Hopefully it will help overcome the problem.

    An alternative that we prefer not to use is to diable iDRAC.

    Thank you.



  • 13.  RE: ESXi on DELL R710 Network Problems

    Posted Oct 12, 2011 03:30 PM

    you should be able to keep iDRAC on the static ip as that is assigned to the managment of the physical hardware, when installing ESXi you should then assign an IP for that which will be for ESXi management then once guest OS is installed it should pick up DHCP or you can assign a static IP as you would normally



  • 14.  RE: ESXi on DELL R710 Network Problems

    Posted Oct 13, 2011 02:10 PM

    Hi Again,

    Jumped back on teh machine again and ran a few tests. Note the following:

    + ESXi is the only item loaded on the machine

    + Using 2 x NIC Cards out of 4.

    iDRAC IP: 192.168.100.205

    ESXi IP: 291.168.100.202

    Gateway: 192.168.100.1

    From the network using a PC:

    Ping Gateway: OK

    Ping iDRAC: OK

    Ping ESXi:  Destination Host Unreachable

    Open Internet Explorer:

    iDRAC: Open no problem full access

    vSphere Client: No response from Host

    From ESXi Management Console on Machine (not the tech support console):

    Ping ESXi: OK

    Ping iDRAC: Failed

    Ping Gateway: Failed

    Resolve Hostname (localhost): Failed

    Network Management

    NIC 0: Used and connected

    NIC 1: Used and connected

    Should we set the IP address used by iDRAC as the ESXi gateway? At the moment we are setting the LAN gateway on our router. Or is there something else we should be doing to tell ESXi that the rest of the network is on the other side of the NIC Cards?

    Thanks!



  • 15.  RE: ESXi on DELL R710 Network Problems

    Posted Oct 13, 2011 02:24 PM

    Dziękuje za wiadomość. Uprzejmie informuje, że jestem poza biurem bez dostępu do poczty do 17.10.2011. W sprawach pilnych proszę wysyłać SMS.

    Thank you for your message. Please be informed that I am out of office with no access to e-mail to 17.10.2011. In any urgent matters please send SMS.



  • 16.  RE: ESXi on DELL R710 Network Problems

    Posted Oct 13, 2011 07:54 PM

    Are your  two nics setup using a ether channel ? Have you tried to see what happens if you remove the network cable from one of the nics while still keeping it assigned to the team ?



  • 17.  RE: ESXi on DELL R710 Network Problems

    Posted Oct 13, 2011 09:02 PM

    Hi,

    Yes we haev tried removing one network cable and no change in results. We have also tried removing one NIC card in ESXi and nothing either.

    We have configured the local switch with all ports on VLAN 1 and set ESXi to same VLAN. Have also tried setting VLAN to 4095 no luck.

    Any ideas?



  • 18.  RE: ESXi on DELL R710 Network Problems

    Posted Oct 13, 2011 10:27 PM

    Hi,

    I have changed iDRAC NIC settings from "shared" to "shared with failover: ALL LOMS. The ping response on teh ESXi host IP has now changed from "destination host unreachable" to "request timed out".

    Does this get me any closer to a solution? Where should I look next?

    Thank you!



  • 19.  RE: ESXi on DELL R710 Network Problems

    Posted Oct 16, 2011 02:04 AM

    Ok, so I have a partial solution.

    iDRAC disabled and ESXi is able to operate as normal. Presently only using 1 NIC but next step will be to attempt:

    1. Add iDRAC to a separate NIC with different IP address.

    2. Add second NIC to ESXi fro redundancy and make necessary changes to local switch.

    Assuming the above two steps work we will then try to separate the iDRAC and ESXi VLANs.

    Will update again for anyone else in the same or similar boat.