ESXi

 View Only
  • 1.  ESXi - Acronis vmProtect 7 - Fails

    Posted Mar 04, 2013 09:56 AM

    Hello,

    I've got a machine running ESXi 4 with 5 VM's + 1 AcronisAppliance with vmProtect 7. Untill last week, everything worked fine. There was not a single problem with the backups. I Did some Windows Updates on the machines, and now the backup is failing. I'm not sure if the problem has anything to do with the Windows Backup, but the problems started at that day..

    I've got a task that will backup the entire physical server, 5 VM's. Everything goes ok but when it starts to backup my SBS2011 server, it fails (See VM Log below). The SBS2011 server itself is throwing some warnings; The system failed to flush data to the transaction log. Corruption may occur. A few days ago it was throwing some errors that my Disk wasn't ready for acces yet.

    What i've done so far:

    - Completely updated SBS2011.

    - Reboot the server (+3 times).

    - Recreated the vmProtect task.

    - Reïnstalled vmprotect.

    - Rebooted my NAS (+3 times).

    - Updated VMware tools (8.6.5).

    When I disable the VMware Tools Service, the backup will succeed with a warning that my backup isn't consistent. When I enable the service again, it fails.

    Is there anything I can try/do to fix this problem?

    Thank you very much in advance,

    Jente

    Failed to perform the requested operation.
    Additional info:
    --------------------
    Error code: 13
    Module: 149
    LineInfo: d1ab7fa1e56ec8b7
    Fields:
    Message: Failed to perform the requested operation.
    --------------------
    Error code: 103
    Module: 83
    LineInfo: a859dd78cc91de7b
    Fields:
    Message: Failed to open the virtual machine ([Store-raid5] SBS2011/SBS2011.vmx).
    --------------------
    Error code: 64
    Module: 83
    LineInfo: c7610e0a857bedda
    Fields:
    Message: VMware error: 'An internal error.'.
    --------------------
    Error code: 52
    Module: 0
    LineInfo: c7610e0a857bedda
    Fields:
    Message: Awaiting task 'CreateSnapshot' has failed. Reason: An error occurred while quiescing the virtual machine. See the virtual machine's event log for details..
    --------------------



  • 2.  RE: ESXi - Acronis vmProtect 7 - Fails

    Posted Mar 04, 2013 11:10 AM

    Hi,

    Uninstall VMware Tools in  your VM and try to install it in custom. Unselect " Volume Shadow Copy Service " or VSS and then install VMware Tools.

    You can also use another backup tools such as Veeam Backup & Replication Free Edition.

    Try it and let me know any issue further.



  • 3.  RE: ESXi - Acronis vmProtect 7 - Fails

    Posted Mar 04, 2013 12:07 PM

    Using another backup tool isn't an option. I Will try to reïnstall VMware Tools. I hope I don't encounter any problems.



  • 4.  RE: ESXi - Acronis vmProtect 7 - Fails

    Posted Mar 04, 2013 01:05 PM

    Hello,

    I've tried this option. Now I see the same warning when disabling the VMware tools service > Inconsistent.  This is giving me a false feeling of having a good backup.

    Isn't there a fix for this problem?



  • 5.  RE: ESXi - Acronis vmProtect 7 - Fails

    Posted Mar 05, 2013 06:44 AM

    Hi,

    you have snapshot of that VM or not? Is it important ro not? if it isn't important, you can delete it and try again to take backup.

    You can delete snapshot from Snapshot Manager. In VI, right click on the VM and in snapshot menu click Snapshot Manager.

    Hope this resolve problem.

    Good Luck!



  • 6.  RE: ESXi - Acronis vmProtect 7 - Fails

    Posted Mar 05, 2013 07:46 AM

    Hi,

    At this moment this virtual machine doesn't have a single Snapshot.

    I'm currently doing backups with the VMware Tool Service disabled. It works, but the backup is incosistent so I don't trust it.



  • 7.  RE: ESXi - Acronis vmProtect 7 - Fails

    Posted Mar 07, 2013 03:50 PM

    Hello Jente,

    Thank you for using Acronis software.

    My name is Anton and I'm writing you on behalf of Acronis Customer Central.

    Please let me know if this solution from our Knowledge Base works for you - http://kb.acronis.com/content/4559

    Let me know if there is anything we also can do for you please.

    Thank you.

    Anton Deev

    Acronis Customer Central



  • 8.  RE: ESXi - Acronis vmProtect 7 - Fails

    Posted Mar 13, 2013 12:24 PM

    Hello,

    Uninstalling/Reinstalling VMWare Tools isn't that simple since we are in an operational environment. We decided to wait for an VMWare Tools update and are hoping that this will solve this problem.

    Jente