Automation

 View Only
  • 1.  esxcli Software Error

    Posted Sep 25, 2012 03:35 AM

    Hi All,

    I wasn't able to post this in the PowerCLI section as it looks to be restricted to developers so this is the closest forum I could find.

    I'm trying to follow some instructions from a Dell website to check if the VIBs were migrated across after I ran an update from 5.0 -> 5.1 via VUM.

    The command is:      esxcli software vib list|grep -i open

    when even running esxcli software I receive the error:

    Get-EsxCli : 25/09/2012 10:48:12 AM    Get-EsxCli        The method or operatio
    n is not implemented.
    At line:1 char:7
    + esxcli <<<<  software
        + CategoryInfo          : NotSpecified: (:) [Get-EsxCli], VimException
        + FullyQualifiedErrorId : Core_BaseCmdlet_UnknownError,VMware.VimAutomatio
       n.ViCore.Cmdlets.Commands.GetEsxCli

    This is after I've run:     Connect-VIServer and received confirmation that i've connected with the output:

    Name                           Port  User
    ----                           ----  ----
    vm04                           443   root

    The original instructions i'm following can be found here:

    http://www.dell.com/support/drivers/au/en/aulca1/DriverDetails/Product/poweredge-r710?driverId=W32PK&osCode=XI51&fileId=3006491785

    ..under "Using the Power CLI"

    Any help or if someone could point me in the right direction would be much appreciated!

    Regards,

    Jon



  • 2.  RE: esxcli Software Error

    Posted Sep 25, 2012 11:11 AM

    Discussion moved from VMware ESXi 5 to VMware vSphere™ PowerCLI



  • 3.  RE: esxcli Software Error

    Posted Sep 25, 2012 11:17 AM

    Which PowerCLI version are you using ?

    Do a

    Get-PowerCLIVersion

    The last version is 5.1.

    If you're running an older version can you first try to upgrade.



  • 4.  RE: esxcli Software Error

    Posted Sep 26, 2012 12:51 AM

    Hi LucD,

    I downloaded and installed the latest version from the VMware site and still get the same error:

    PowerCLI Version
    ----------------
       VMware vSphere PowerCLI 5.1 Release 1 build 793510
    ---------------
    Snapin Versions
    ---------------
       VMWare AutoDeploy PowerCLI Component 5.1 build 768137
       VMWare ImageBuilder PowerCLI Component 5.1 build 768137
       VMware vCloud Director PowerCLI Component 1.5 build 793505
       VMware License PowerCLI Component 5.1 build 669840
       VMware vSphere PowerCLI Component 5.1 build 793489



  • 5.  RE: esxcli Software Error
    Best Answer

    Posted Sep 26, 2012 06:56 AM

    The "esxcli software vib list" command is a VMware vCLI command. In PowerCLI you can do this as follows (replace MyHost with the name of your ESXi server):

    $EsxCli = Get-EsxCli -VMHost "MyHost"

    $EsxCli.software.vib.list()




  • 6.  RE: esxcli Software Error

    Posted Sep 26, 2012 08:42 AM

    Thank You RvdNieuwendijk!

    So did I misinterpret the Dell instructions somewhere?  Or were their instructions incorrect?  It clearly says PowerCLI (Or is that different from VMware PowerCLI?)

    Btw, where did you find this info?  There are other commands that i'd like to know the equivalent for such as:

    Install-VMHostPatch -VMHost 10.94.171.97 -HostPath /vmfs/volumes//OMSrvAdmin-Dell-Web-7.1.0-.VIBESX51i/cross_oem-dell-openmanage-esxi_7.1-0000-metadata.zip



  • 7.  RE: esxcli Software Error

    Posted Sep 26, 2012 11:15 AM

    In the Dell instructions where they say:

    11 Run the following command to check if OpenManage is installed successfully on the host.
    esxcli software vib list|grep -i open
    OpenManage is displayed.


    they mean run this command locally on the ESXi server. I must admit that it is not obvious if you are not familiar with PowerCLI.

    The command:

    Install-VMHostPatch -VMHost 10.94.171.97 -HostPath /vmfs/volumes//OMSrvAdmin-Dell-Web-7.1.0-.VIBESX51i/cross_oem-dell-openmanage-esxi_7.1-0000-metadata.zip


    is a PowerCLI command. So you don't have to find an equivalent.

    I can't remember where I learned about converting esxcli commands into PowerCLI. Probably from the PowerCLI documentation or some blog posts. I wrote a blog post myself about using esxcli from PowerCLI: How to list all the PowerCLI ESXCLI commands. Maybe this is helpful for you?