vCenter

 View Only
  • 1.  Errors when upgrading VC

    Posted Nov 06, 2008 12:43 PM

    We are upgrading from VC 2.0.2 update 1 to VC 2.5 update3.

    Our upgrade is failing when it reaches the connecting to SQL database. It says we need to use a SQL native client. We currently use ODBC drivers to connect to SQL for current VC and it works fine. I have attached the errors as screenshots. Does anyone know why we are getting these error messages.



  • 2.  RE: Errors when upgrading VC

    Posted Nov 06, 2008 01:21 PM

    Hi, the SQL native drivers are required for VC2.5 to talk to a MSSQL2005 database server. If you look on your SQL2005 install CD you'll see the native drivers on there, just install them on the VC server and you will probably need to update your DSN settings (from start -> run -> odbcad32 -> System DSN) to use the Native driver instead.



  • 3.  RE: Errors when upgrading VC

    Posted Nov 06, 2008 02:43 PM

    Agree with NTurnbull,

    Get the SQL native client from the CD or download off MS.

    As stated by NTurnbull you will need to update your ODBC drivers on your Virtual Center.

    HTH



  • 4.  RE: Errors when upgrading VC

    Posted Nov 06, 2008 03:04 PM

    Hi,

    We have changed to SQL native client and now can progress further in the installtion. It has upgraded the Virtual centre software but when it comes to upgrading the database, the database upgrade fails and then it begin the rollback process. While cleaning the database it fails and now I says the database is in a consistent state.

    We badly need assistance now.

    I have attached the log.



  • 5.  RE: Errors when upgrading VC

    Posted Nov 06, 2008 03:08 PM

    Did you want to clean the Database? i'm sure when i ran my upgrade i selected not to do that so it would keep our VC configuration as is.

    Simon



  • 6.  RE: Errors when upgrading VC

    Posted Nov 06, 2008 03:43 PM

    Hi,

    Please provide more info on your setup,

    Is your VC and SQL both physical?

    Versions of OS on both boxes?

    Do you have a DBA to show this errors?

    I did have errors during the upgrade and actually had to call support. The culprit was with SQL authentication in our case.

    Original password for the SQL account was not documented and I overwrote it on the SQL side and in ODBC drivers and in VC through the command line and it still did not work even though ODBC check was successful. To make long story short, 3 hours later DBA finally re-called original password and I put it back, then upgrade completed successfully...

    Alex



  • 7.  RE: Errors when upgrading VC

    Posted Nov 06, 2008 04:43 PM

    Haven't seen that error before (and seen a fair few on DB upgrade!) - Your environment (to carry on from aldikin's questions)

    What method of authentication are you using for the database - NT integrated or SQL (mixed mode)? If your DB is on another host then for 2.5 you must use SQL (mixed mode).

    What permissions does the user have in SQL? Must have DB-Owner to master and the VC database.

    The other thing is how important are your performance stats? You could always ditch the DB and install from fresh - kinda defeats the object though...



  • 8.  RE: Errors when upgrading VC

    Posted Nov 07, 2008 11:25 AM

    From speaking to Vmware, they have told us that our SQL 2005 where the database resides is case sensitive. Because of this reason the upgrade fails. We do not want to look into changing the case sensitive setting to mix as I dont know how other dbases on this SQL server will react.

    So we are going to move the dbase to another SQL server which is SQL 2005 where the case sensitive is mixed and try the upgrade again. If this fails then we are just going to do a fresh install of VC 2.5 and just start again.