vSphere Availability

 View Only
  • 1.  Error while enabling HA

    Posted Aug 17, 2010 06:02 AM

    Hi all,

    at my 8 node cluster, i have a problem while enabling ha on one of my host. I have to shut the host down because of a memory error. Aftermaintanance mode and reboot the host, it´s not possible to enable ha again. I´ve check name resolution, time sync and so on. But it works for a long time. I have vsphere 4u2 installed. I´ve also detach that host from the cluster an back. That does not work either.

    I check out the log files at that host and saw that error

    08/16/10 11:18:09 CMD: /opt/vmware/aam/bin/ft_gethostbyname esx01 |grep FAILED

    08/16/10 11:18:09 STATUS: 1

    08/16/10 11:18:09 RESULT:

    08/16/10 11:18:09

    08/16/10 11:18:09

    08/16/10 11:18:09 command is '/opt/vmware/aam/bin/ftcli -domain vmware -port 8042 -timeout 15 -cmd listnodes'

    08/16/10 11:18:09 CMD: /opt/vmware/aam/bin/ftcli -domain vmware -port 8042 -timeout 15 -cmd listnodes

    08/16/10 11:18:09 STATUS: 1

    08/16/10 11:18:09 RESULT:

    08/16/10 11:18:09 Cannot connect to a secondary agent

    08/16/10 11:18:09

    08/16/10 11:18:09 copying /var/lib/vmware/aam/vmware-sites to /var/log/vmware/aam/aam_config_util_listnodes.log

    FULLTIME_SITES_TID 00000001

    + 1:8042,8042,8043 esx02 vmware #FT_Agent_Port=8045

    08/16/10 11:18:09 Failure location:

    08/16/10 11:18:09 function main::myexit called from line 212

    08/16/10 11:18:09 VMwareresult=failure

    08/16/10 11:18:09 Total time for script to complete: 0 minute(s) and 0 second(s)

    That seems to me a name resoution error. But that works well.

    The error at my vcenter is " cmd addnode failed for primary node: /opt/vmware/aam/bin/ft_startup failed to complete within 3 minutes.

    And we also never use jumbo frames in our environment.

    It´s only a guesswork but is it possible that the host is not able to check out which host is primary and which secondary?

    I´ve opened a call. But HP is.............

    Any hints will be helpful.

    Frank

    If you find this information useful, please award points for "correct" or "helpful".



  • 2.  RE: Error while enabling HA

    Posted Aug 19, 2010 03:35 PM

    DNS issues? Did you add your hosts with their fqdn to vCenter?



    Duncan

    VMware Communities User Moderator | VCDX

    -


    Now available: <a href="http://www.amazon.com/gp/product/1439263450?ie=UTF8&tag=yellowbricks-20&linkCode=as2&camp=1789&creative=9325&creativeASIN=1439263450">Paper - vSphere 4.0 Quick Start Guide (via amazon.com)</a> | <a href="http://www.lulu.com/product/download/vsphere-40-quick-start-guide/6169778">PDF (via lulu.com)</a>

    Blogging: http://www.yellow-bricks.com | Twitter: http://www.twitter.com/DuncanYB



  • 3.  RE: Error while enabling HA

    Posted Aug 19, 2010 04:06 PM

    There's a KB article which describes the symptoms you see - http://kb.vmware.com/kb/1018146

    André



  • 4.  RE: Error while enabling HA

    Posted Aug 20, 2010 12:22 PM

    Hi,

    i saw all the articles. Butwe never use Jumbo frames bevor and at the moment. So all other hosts works well.

    What i saw in the Logfiles was that the host has a problem to connect to our esx02 host to enable ha. I don´t know why. Because DNS is configured well. Ping and nslookup from alls esx hosts and the vcenter works perfect.

    I took the esx02 in manintanace and after that, i enable ha on the esx01. And it works.HA could be enable. After that, i´ve disable maintanance mode for esx02 and HA works well for that host.

    What i saw while testing around was, that everytime, i enable HA or reconfiure HA for esx01, it makes a host entry for the esx02. And not with the domain name. Only the hostname. After changing the DNS policy from file to dns the same entry appears. Now, after esx02 was in maintanance mode, esx03 become a hosts file entry. I´ve done a second entry with the DNS name of esx02. But that do not work either.

    Everything looks very strange for me. And HP ist looking deeply at the logfiles. When i´ve got some news, i will let you know.

    Frank

    If you find this information useful, please award points for "correct" or "helpful".