ESXi

 View Only
  • 1.  error: broken pipe on virtual disk in esxi4

    Posted Jun 26, 2009 09:38 PM

    Hi,

    I have recently bought a brand new HP ProLiant ML110 (G5) for my VMware environment at home - which is going great so far

    I have successfully migrated 2 windows server 2008 virtual machines from my old Vmware Server 2 (running on ubuntu server 64-bit) by just copying the virtual hard disks across and creating new virtual machines with those disks on the new box. I have a third 2008 VM which is having some issues though. When you try to boot up the virtual machine the vSphere client displays the following message:

    "Cannot open the disk '/vmfs/volumes/blah.../File Server/os/FileServer.vmdk' or one of the snapshot disks it depends on. Reason: Broken pipe."

    This disk was working perfectly fine just this morning on the old box, so I am unsure as to why it has failed. Below is the contents of the .vmdk file - I cannot see anything obviously wrong with it at the moment, but I have not been on the virtualisation bandwagon for very long, and am far from an expert in it

    1. Disk DescriptorFile

    version=1

    encoding="UTF-8"

    CID=540e3393

    parentCID=ffffffff

    createType="twoGbMaxExtentSparse"

    1. Extent description

    RW 4192256 SPARSE "File Server-s001.vmdk"

    RW 4192256 SPARSE "File Server-s002.vmdk"

    RW 4192256 SPARSE "File Server-s003.vmdk"

    RW 4192256 SPARSE "File Server-s004.vmdk"

    RW 4192256 SPARSE "File Server-s005.vmdk"

    RW 4192256 SPARSE "File Server-s006.vmdk"

    RW 4192256 SPARSE "File Server-s007.vmdk"

    RW 4192256 SPARSE "File Server-s008.vmdk"

    RW 4192256 SPARSE "File Server-s009.vmdk"

    RW 4192256 SPARSE "File Server-s010.vmdk"

    RW 4192256 SPARSE "File Server-s011.vmdk"

    RW 4192256 SPARSE "File Server-s012.vmdk"

    RW 24576 SPARSE "File Server-s013.vmdk"

    1. The Disk Data Base

    #DDB

    ddb.virtualHWVersion = "7"

    ddb.uuid = "60 00 C2 90 58 26 ac 7e-55 a7 bf ee d1 05 08 ff"

    ddb.geometry.cylinders = "3133"

    ddb.geometry.heads = "255"

    ddb.geometry.sectors = "63"

    ddb.adapterType = "lsilogic"

    ddb.toolsVersion = "7397"

    I have attached the file aswell because this forum converts the number signs to actual numbers!

    Any advice on this situation would be great,

    Thanks - Aaron Trout



  • 2.  RE: error: broken pipe on virtual disk in esxi4

    Posted Jun 26, 2009 10:48 PM

    Did your server install have any uncommitted snapshots? Post your vmx from the old server.



  • 3.  RE: error: broken pipe on virtual disk in esxi4

    Posted Jun 26, 2009 10:54 PM

    Hi,

    Thanks for the quick reply. The VM on the old server did not have any snapshots, if I am using snapshots I always remove them after I am done. Also unfortunately I do not have the original vmx file, but if you just wanted to confirm there were no snapshots, I have never made a snapshot from this machine as it is only a file server (with DFS) and also has IIS & MySQL/PHP. There are two other virtual disks (which seem to be working) on this VM aswell if that means anything.

    Thanks,

    Aaron



  • 4.  RE: error: broken pipe on virtual disk in esxi4

    Posted Jun 27, 2009 12:00 AM

    If you can, watch the log files on the ESXi host while you start the VM. See if there is anything helpful. Get to the real time logs ALT+F12

    You could try running converter against the VM. Run against the running machine on server with the destination as ESXi host.



  • 5.  RE: error: broken pipe on virtual disk in esxi4

    Posted Jun 27, 2009 10:42 PM

    Hi,

    The logs were not really that useful, but I had an idea - which was to use WinImage to convert the virtual disk files from a vmware disk to a vmware disk. This actually worked, even though it sounds like it would do nothing. I think the reason that the disks were broken was from me trying to shrink them using vmware tools from inside the virtual machine. The firs time i tried this the vmware tools process crashed, so probably left something on the disk corrupt. This still doesn't explain why they still worked on the old vmware server 2 box, but oh well - its working now!

    Thanks for all your help

    Aaron



  • 6.  RE: error: broken pipe on virtual disk in esxi4

    Posted Jun 27, 2009 11:00 PM

    Glad it's working.

    Have fun. :smileywink:



  • 7.  RE: error: broken pipe on virtual disk in esxi4

    Posted Jun 27, 2009 11:02 PM

    Converter would probably have worked as well. If you haven't, download it. Great tool for copying, semi hot moving etc.