ESXi

 View Only
  • 1.  Detected Invalid Snapshot Configuration Error

    Posted Dec 02, 2009 02:33 AM

    I had a vm with two virtual disks. One of the virtual disks was stored with the vm and other one on a different datastore.

    The vm was running on two snapshots. The snapshots were taken using both the options: quiescing the guest filesystem and dump the vm memory.

    To backup this vm I created another snapshot of this vm using both above said options and after backup completed I deleted this third snapshot.

    Now to I want to restore my vm on the same ESX host as the original vm is no longer there. The files were :

    <vmname>.vmx

    <vmname>.vmxf

    <vmname>.vmsd

    -


    <vmname>-flat.vmdk --->

    <vmname>.vmdk -


    >

    -


    these two also on a separate datastore.

    <vmname>-000001.vmdk ---> points to <vmname>.vmdk as parent

    <vmname>-000001-delta.vmdk

    <vmname>-000002.vmdk -


    points to <vmname>.vmdk on separate datastore as parent.

    <vmname>-000002-delta.vmdk

    <vmname>-000003.vmdk --- > with <vmname>-000001.vmdk as parent

    <vmname>-000003-delta.vmdk

    <vmname>-000004.vmdk --- > with <vmname>-000002.vmdk as parent

    <vmname>-000004-delta.vmdk

    plus the nvram, swap file.

    Additionally at the time of backup vmx was refering to <vmname>-000005.vmdk and <vmname>-000006.vmdk as disks as this snapshot was merely made for backup. After uploading files to respective datastores. I edited vmx file to point to <vmname>-000004.vmdk and <vmname>-000003.vmdk . I also edited the .vmsd file and corrected the path to the vmdk for the first snapshot section i.e. I corrected the "/vmfs/volumes/XXXXX..." path for the vmdk that is stored on a different datastore. I also edited the "parentFileNameHint" property of <vmname>-000002.vmdk to the correct "/vmfs/volumes/XXXXX..." path for the parent vmdk that is stored on a different datastore.

    Then I could register this vm by right clicking the vmx file and doing add to inventory. Now in the snapshot manager I can see all my three snapshots. When I want to revert to my third snapshot I get this error: Detected Invalid Snapshot Configuration. Basically I wanted to revert to my third snapshot created only for the virtue of backup and then delete that snapshot. This procedure worked fine for when all the virtual disks were with the vm in same datastore. Please suggest how to proceed in this case now.

    regards

    vohra



  • 2.  RE: Detected Invalid Snapshot Configuration Error

    Posted Dec 02, 2009 02:50 AM

    I am not sure if this will help, please try to use the vmware converter and see what happens. I am sure atleast it wont destroy your data. So no harm in trying.

    Thanks



  • 3.  RE: Detected Invalid Snapshot Configuration Error

    Posted Dec 03, 2009 03:21 AM

    Hi

    Thanks for replying we actually do not have VMware Convertor in our organization. Not sure how to recover data in this case may be what I am doing is not even feasible.

    regards

    vohra



  • 4.  RE: Detected Invalid Snapshot Configuration Error

    Posted Dec 03, 2009 01:09 PM

    it is a free tool that can be downloaded from the internet.

    Thanks