vCenter

 View Only

Deleting unaccesible datastore

  • 1.  Deleting unaccesible datastore

    Posted Jul 08, 2021 09:19 AM

    Hello,

    I have VCSA 6.7 as a vCenter server and cluster with some hosts and datastores (SAN FC connect).

    I have one datastore with old disks for my archive, ISO's and some templates in content library.

    So, month ago, this datastore has some issues, it was have some affects to my cluster and i lost normal connection to it. So i decided to disconnect it via LUN unmapping from my HP P2000 G3. Then this datastore was marked by VCSA as inaccesible.

    I dismount all ISO's on my servers, and check that no one can try to use any data from this inacessible datastore, because i want to delete this datastore from VCSA. I've checked my connections from all hosts in HBA adapters menu, and it is ok.

    But i still can not delete datastore (button is greyed and inactive).

    I've tried to move datastore in maintance mode but it stuck on 1% progress and does not move.

    I found, that i have 2 templates in Content library, that was on this datastore, so i decided that is the problem.

    I've tried to delete templates or group at all from Content library menu, but i have errors, because datastore inaccesible.

    First error:

    A general runtime error occurred.

    Second error:

    Datastore 'VM+Mail Archive +ISO's' is not accessible. "No connected and accessible host with required privilege is attached to this datastore."

     

    What i must to do with this templates?